Skip to main content

The smaller of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

138 Questions View all

MacBook runs on battery and has an LED on MagSafe but “Not Charging”


I have a MacBook Air A1465 11”. I’m facing an issue whereby it runs fine on battery with no issues whatsoever but will not charge!

When plugged into the MagSafe adaptor i’m seeing an orange LED suggesting the charger is communicating with the laptop ok (and supposedly charging the laptop).

The issue is the laptop isn’t actually charging. When I select the battery icon in the top corner it says “power source: AC Adapter” and “not charging” the laptop battery is currently on 55% charge.

I’ve reset the SMC but had no luck so far. I have a replacement DC board arriving today too. If it’s not the DC board (or charger - I’ve tried 3 different MagSafe adaptors, all confirmed working on another MacBook) what should I look into next?

Things to note are, the laptop is running with a Samsung 960 Evo NVMe SSD, the laptop had no SSD a when I purchased it. This drive works ok though so I don’t think the issue is related

thank you.

Snapshots of CocoanutBattery:


Block Image


Block Image

Answer this question I have this problem too

Is this a good question?

Score 0


Let's get a better diagnostic before you alter things. Install this gem of an app CoconutBattery take a snapshot of the apps window and post it here for us to see. If you can do one with the MAgSafe connected and a second with it disconnected (wait a minute to the app resets) Adding images to an existing question you may really need a new battery.


Hello! Thank you for your reply.

I’m away from the laptop at the moment but from memory CocoanutBattery was showing a power consumption of 7W while unplugged and a charging current of 10W while plugged in. The battery is in “good” health and has 171 cycles. It’s at 92% of its original capacity. I will post a snapshot this evening!!

Thank you for your help so far!


Just uploaded screenshots


Add a comment

2 Answers

Most Helpful Answer

Well Coconut Battery shows it to be charging. At this point I would try to calibrate it.

  1. Charge it to 100%, and keep charging it for at least two more hours.
  2. Unplug your laptop and use it normally to drain the battery.
  3. Save your work when you see the low battery warning.
  4. Keep your laptop on until it goes to sleep due to low battery.
  5. Wait at least five hours, then charge your laptop uninterrupted to 100%.

Was this answer helpful?

Score 2


Thank you mayer,

I’ll give this a go. I’ve left the machine charging overnight though and still its not fully charged!


Leave it plugged in for another day. At this point you have nothing to lose except some time.


I’ve left the computer on charge for a while now sadly with no luck!

Yesterday evening I disconnected the battery and held down the power button, I left the computer like this for about 10 minutes before reconnecting the battery and charger. This must have cleared or “bypassed?” The SMC as the fans ran at full speed, I get no keyboard backlight and no battery was detected etc.

I left it in this state overnight on charge using a 60W MagSafe adaptor and reset the SMC using Shift + Ctrl + Alt in the morning. Miraculously the battery has gone from 41% to 86%!

Would this suggest a bad SMC or maybe a bad sensor on the logic board?


Add a comment

@sir_mardle - Your battery and the charging seem to be OK here. Lets try a SMC reset to see if that helps How to reset the System Management Controller (SMC) on your Mac I would also check your charger making sure its a real unit OEM MagSafe Chargers vs Cheap Imposters: Teardown for Truth as well as make sure the MagSafe cable is in good shape and the connector contacts are clean and shiny Apple Portables: Troubleshooting MagSafe adapters if they are pitted or off color you will need to replace them.

Was this answer helpful?

Score 0


Hi Dan!

Thank you for your advice regarding the actual charging port. I’ve noticed a small amount of dirt in one of the outer pins, I believe these are used for the GND connection. I’ll try to clean them out this evening and see if that resolves the issue. As for the SMC, I’ve reset it a couple of times but still no luck. All of my AC adaptors are confirmed genuine.

Thank you for your superb advice so far!


Ok! I’ve cleaned all of the connectors given the SMC and PRAM another reset and checked for stuck pins on the MagSafe connector.

Sadly none of this has fixed the issue yet. Could it be a bad SMC? Also when I got the computer the battery was fairly discharged, could this disable the battery?

Thank you


I think SMC is working correctly here. Whats more likely the issue is the MagSafe connector and its logic within the I/O board MacBook Air 11" (Mid 2013-Early 2015) I/O Board The logic on it works with the one-wire communication between the battery and the SMC.


Hi Dan,

Thanks again for your help with this!

I’ve installed the replacement I/O board and sadly the problem remains.

I tested both I/O boards and with no battery the computer seems to turn on then dies suggesting a lack of power. If I hold the power button and reconnect the charger it must clear the SMC as the fans spin up and I get no keyboard backlight etc. But the computer will boot up MacOS. I mentioned this in further detail to @mayer.

Running Apple diagnostics revealed an error code related to the SSD. I’ve located a genuine Apple drive and will install this when it arrives although I don’t think the error would effect charging.

What would you recommend I test next?


Add a comment

Add your answer

Oliver will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 111