Skip to main content

Repair guides for the Lenovo IdeaPad 330S-15IKB. Released in 2015.

13 Questions View all

Doesnt turn on after I disassemblied for cleaning

So i disassembled my lenovo ideapad 330s because i wanted to clean the vent... i could see it was pretty dusty. Thought it went well, but after reassembling it, it wont turn on.. No lights when pushing the on button or anything. No reaction when putting the charging cable in either.

Really hope someone can help me to figure out what i did wrong..

I basically took everything apart to clean everything, because i thought i might as well while im at it… turns out that was a mistake, should have kept it simple..

Didnt use water to clean by the way, just a brush and a tooth pick.

Maybe someone can see something wrong in this photo.

Thankful for any help

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

Hi Hanna,

Have you downloaded the pdf service manual? You might find it useful. Shows all screws, etc.

The connector with no ribbon cable connected just the the left of your yellow circle is connected in the service manual. I would investigate this. It seems to come from under the battery.

The black and red wires you mention are for the RTC or cmos battery, which stores the BIOS or UEFI settings and the time, but this would not stop it powering on.

It is vitally important that all cables are correctly inserted. All the parts of the machine are interconnected and dependant on each other. The problem may be that some thing you did incorrectly the first time you have repeated each time. Read and study the service manual and review what you have done….oh and always shut down and disconnect the battery.

I still suspect your problem is just a cable especially as you get no power lights what so ever.

Let us know how it goes. Everything has a cause. Every problem has a solution and usually a simple one. The hard part is finding that simple solution.

Was this answer helpful?

Score 2

1 Comment:

Just another thought.

Have you been flipping the black, ribbon cable, locking bar up when pulling the cable out and pushing it back down again once re-inserting to lock it?

The service manual will show you this quite clearly.

Good luck!


Add a comment
Most Helpful Answer

I don’t think the keyboard cable is seated fully into the keyboard connector on the board. Generally the individual lines which are visible at the end of the keyboard cable should not be visible and be inside the connector. Try pushing it in a bit while the connector is in the unlocked position.

Was this answer helpful?

Score 2

1 Comment:

Do you mean the cable i circled yellow now in the photo? It really doesnt go in any further... That Wouldnt solve the problem of the laptop not switching or could stuff like that actually be connected?


Add a comment

Hey. In the picture I can’t see anything obvious,other than that ribbon cable connector that has nothing plugged into it on the bottom left of the motherboard. I don’t know if there was anything there or not.. But did you disconnect the battery prior to disassembling? If not,it’s so easy to short circuit something. You can connect a high voltage line to a low voltage line,and it will damage something not meant for high voltage,and maybe short a capacitor.

have you made sure you reconnected every ribbon cable,and that they are all attached very well? Did you unplug the battery and hold the power button to drain some left over power then plug it back in? Is there any sign of heat in the laptop? Did you drop anything at all or shove in a flex cable too hard?

edit: I can see what Ben means. It looks like it’s not pressed in all the way.

Was this answer helpful?

Score 1


Hey, im sure that the empty ribbon cable connector was empty before hand too.

I did not disconnect the battery prior to disassembling… i tried but it might actually not be detachable, at least i dont know how to…

So i might have screwed myself There?

I really think i attached all the ribbon cables well..

Cant really drain power if i cant detach the battery, no sign of heat, dont think i dropped anything, or was rough with the cables


Here’s the problem... those plastic ribbon cables are very easy to have go in at a slight angle when you’re getting it in. It’s easier than you think to short 2 lines.

The battery does have a plug. It is meant to disconnect. I have a Lenovo flex 5,and boy is it a pain to disconnect. But you can pry it out. But I doubt this would cause a no charge and no power issue.

Did you retrace your steps? Make sure no ribbon cable is upside down. This is definitely a possibility.

If you disassembled the whole laptop( took the motherboard out and all),I’d disconnect the battery and go back and unplug everything and plug it back in. Make sure the cables aren’t upside down. I know it seems like I’m insulting you by asking the obvious,but I’m not. It’s just so easy to put in a ribbon cable upside down,especially if you don’t regularly work on electronics.

Let me know how this goes(I highly recommend you follow my advice). Make extra sure the ribbon cables don’t have a bad crease or anything.


When I say I doubt it would cause a no power no charge issue with the battery,I meant I doubt disconnecting and reconnecting would fix that issue,but you never know.

But any further steps you take please make sure you find a way to disconnect it.

I can say before I was more knowledgeable about these things,I plugged in a ribbon cable into a printer while plugged in. It went in at an angle and smoked and shorted. I vowed I’d never make that mistake again. So in your case I can’t say for sure,but I suspect this.


Honestly happy for any suggestions so dont worry about offending me. I'll try what you said and report back


So i actually got the battery unpluged. Disassemblied everything and put it back together, but still no reaction,when i push the on button….

Tried it a second time still nothing… %#*@ really dunno what to Do.

My best guess if i actually put something wrong back together Would be the on switching mechanism side (upper left corner in the photo). What is this yellow circled with the twisted back and red cables coming out of it? I detached that too… could not putting this back extacly at the same place be an issue?


Show 2 more comments

Add a comment

Add your answer

Hanna will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 8

All Time: 985