Skip to main content

Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

1986 Questions View all

iPhone 6s doesn't vibrate

Hi all, I have an iPhone 6s that is driving me crazy/making my life !&&*! It works perfectly in every way except it doesn’t vibrate at all, doesn’t vibrate when plugged in, when set to silent, when ringing or when using 3D touch.

I’ve replaced the taptic engine but still the same result, I’ve checked continuity all the way from the pads on U3800 (under the ARC driver) to the pads at the taptic engine (arc driver to solenoid out +/-) I’ve replaced U3800 (ARC/vibrate driver) and tested the other functions the chip integrates with i.e loudspeaker and 3D touch, I’m not sure if U3800 is responsible for the ‘wake on movement’ feature but that also works ok. I’ve checked for shorts on the various capacitors which are connected. The only thing I’ve not checked is resistor R0921 which seems to be on a CLK line between the CPU and the ARC driver.

I’m ok at replacing parts but I lack the knowledge of how the various IC’s communicate with each other and what is likely or not likely to be a culprit.

Does anyone have any advice before I scrap this phone? It’s so annoying as the vibrate function might seem trivial but to me it’s fairly critical.

Thanks in advance if anyone has any advice.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Also, I forgot to mention I've tried resetting and updating the software.

by

Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

2 Answers

Chosen Solution

Update: The phone is now working with vibrate!

I just thought I’d post an update for this incase anyone else has a similar problem and comes across this thread. After further checking I can confirm the AP_TO_ARC_RESET_L line should only be 1.8v when the phone is vibrating (will be zero until phone is ringing etc, then will be 1.8v).

The solution for my phone was the charging port. Whilst I’d already tried several taptic engines and checked continuity through the charging port, I discovered the vibrate was working when I tried the board in a different housing (with different chargeport). I was about to change the chargeport itself but I was curious about what could be wrong if there’s continuity, I found pin 6 on the chargeport (ARC_DRIVER_OUT_NEG) didn’t have continuity to the taptic engine pad (it had shown as it did before as pin 8 also goes to the same pad). I managed to repair the charging port and now all is working ok.

Thanks again for all your help.

Was this answer helpful?

Score 1

Comments:

Congrats...and lesson learned!

Always test the parts before delving into the board-level stuff. The first bullet I made was "The first thing I would do at this point is validate the condition of my parts."

by

Hi Minho, yes absolutely right, another lesson learned the hard way, the very hard way, having replaced IC's and spent countless hours trying to figure it out on this phone and rebuilding another phone that I'd messed up trying to fix this one. I thought I had validated my parts, but clearly trying the board in another phone could have saved many many many hours..

Thanks again for all your help!

by

Add a comment
Most Helpful Answer

Looks like you did an exhaustive troubleshooting…for someone who says they don’t understand all the interactions, you have done a thorough job!

I don’t have a solution per se but I’ll make a few suggestions which may help you find the problem. Some of these you may have already tried but not documented:

  • The first thing I would do at this point is validate the condition of my parts. Can you try the Taptic engines in a working phone? You have to know 100% that the original and the replacement do indeed work.
  • Is U3800 getting power? Obviously VCC_MAIN works but have you looked at the power on pin 2 of the L3800 coil and PP_ARC_VBOOST? You should be measuring 8V there. I don’t know if the 8V is always there or not which leads me to the next point…
  • Check the AP_TO_ARC_RESET_L line to see if it is Low (0V). That would keep the Arc driver in RESET mode and disable it. Similarly, look at the I2C lines (I2C1_AP_SDA/I2C1_AP_SCL). Check them in diode mode (they should be balanced) and then power the device and measure the voltage (it should read 1.8V).
  • On the right side of the schematic, check the current sense lines for continuity (SOLENOID_TO_ARC_DRIVER_VSENSE_P). There are Resistors and Filters downstream that may have been dislodged or damaged.

Good luck, be sure to report back!

Was this answer helpful?

Score 4

Comments:

Hi Minho, thanks for your message. I've replied below as it wouldn't allow me to comment on your answer. Thanks

by

Hi Minho, thanks for taking the time to send me your suggestions, that’s a really great start of things I can check.

So far, I can indeed confirm the Taptic engines are working in another phone. I’ve been wanting a reason to change L3800, because I was running out of options, but it I’d tested continuity across it and assumed it was ok, I’ve now checked the voltage coming out of L3800 and going to the ARC driver, I was getting excited to see it was only 3.8v, but schematic shows 8.0v, as I didn’t want to remove the shield on a working phone to compare what I definitely should be seeing coming out of L3800, I decided it was simpler to just change L3800… worth a try, but it’s still 3.8v… strange, I’m not sure if there’s a problem there or not. I could check L3700, but that’s under yet another shield!! I’m also only getting 3.8v on PP_ARC_VBOOST

I do have continuity on SOLENOID_TO_ARC_DRIVER_VSENSE_P/N

I’ll check the ARC reset line and I2C1_AP_SDA/I2C1_AP_SCL tomorrow, I’ll let you know what I find!

Thanks again

by

I probed a 6S I had laying around and did not see the 8V either although this device has other issues so I don't know if they are related. I suspect that the voltage is generated when the Reset line is High (that would make sense).

by

Thanks for going out of your way to investigate this on one of your own phones, that's really helpful to know. I think you're right, the 8V is probably only there in certain conditions. I've not had chance to check the reset line and I2C1_AP_SDA/I2C1_AP_SCL yet, I've had a few long days at work this week and also just finished putting another 6s back in one piece after I almost cooked a mostly good phone when trying to use it to help fault find the no vibrate issue, I hate them EMI shields, I was rushing for work and thought I could quickly take the shield off without taking the board out (as I wanted to take the good phone to work with me).. big mistake.. lesson learnt never to do that as it will stress the board and cause components to move around (the complete bottom end of the board in my case :0). Well that's almost sorted now, so I'll try and provide an update by weekend.

Thanks again for your help

by

Hi again, I think we're onto something now, thanks to your advice above, but I'm not sure what can be done next. To summarise, the Taptic engine works ok in another phone L3800 and PP_ARC_BOOST are both measuring 3.8v, not 8v (but I think that could be normal if the ARC driver is disabled. I2C1_AP_SDA and I2C1_AP_SCL are both balanced (read around 0.355 in diode mode) and measure 1.8V when powered. The continuity on the ARC driver to the taptic engine out +/- and solenoid in +/- are all ok.

What I have found thanks to Minho's comments above is that the AP_TO_ARC_RESET_L line is measuring 0V. As the phone is booting, this line gets 1.8v for a second or so and then drops back to zero, so I think this is something to investigate further, but I'm not sure what I could try next.

Any advise is greatly appreciated.

by

Show 3 more comments

Add a comment

Add your answer

Darren will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 70

All Time: 105