Skip to main content

Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1217 Questions View all

SSD upgrade won’t install MacOS even after cable replacement

Hi,

I have a mid 2012 MacBook Pro that I am trying to upgrade to an SSD. I’ve already upgraded the RAM.

I’m installing a fresh copy of MacOS so I didn’t clone the drives or anything fancy.

The MacBook works fine with its original HDD. But when I have tried to install MacOS on the SSD, it doesn’t work. I always get a “Could not install macOS”.

I replaced the HD SATA cable as well. I’m trying to install High Sierra but also can try Mojave if you think it’s worth a try.

I have bought a cheap Silicon Power 128 GB SATA III SSD, and am very confused as to why it’s not working.

Here’s the link to the SSD- Silicon Power 128GB SSD 3D NAND A55 SLC Cache Performance Boost SATA III 2.5" 7mm (0.28") Internal Solid State Drive (SU128GBSS3A55S25AC) https://www.amazon.com/dp/B07D7VTDNB/ref...

The person who owns this laptop has been waiting a while for me to get it fixed and it’s frustrating that it keep failing.

I think it did get farther in the install after the cable replacement, but still failed to install.

Please let me know what the issue could be, Thanks!

Update (06/17/2019)

I got the ifixit cable, and it still gives me the same error. I don’t know what to do. I really would like this SSD in this Mac and it’s getting really irritating. I’m going to try and install Sierra and see if HFS treats this nicer.

Update (06/17/2019)

I got it working!!! Thank you guys for all the help! I ended up installing Sierra and formatting to HFS which thankfully worked because getting that DMG to a flash drive was super sketch. Then I updated to Mojave and the computer works great! Even under APFS!

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Can you tell us which SSD Silicon Power SSD's

by

Yes! Just added the link

by

Here's the makers spec sheet: Ace A55

by

How is the drive formatted? GUID or APFS

by

I believe it’s is APFS, I don’t even know how to make it GUID

by

Show 2 more comments

Add a comment

iPhone Battery Fix Kits

Only $29.99

Buy Now

iPhone Battery Fix Kits

Only $29.99

Buy Now

1 Answer

Chosen Solution

First the original HD SATA cable is only rated for SATA II (3.0 Gb/s) drives as that is what Apple put in until the very end of the run of the series. At that point Apple improved the cable to support the faster SATA III (6.0 Gb/s) HD drives they where installing.

You do need to be careful you get the better cable as some folks are still selling the older version. Make sure you’ve gotten the better cable MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable.

In addition to getting the better cable, you also need to place a strip of electricians tape on the uppercase where the cable crosses over as the rough aluminum surface can wear the cable. The last thing is the bends, you don’t want to fold the cable with a sharp fold as that will damage it! Instead you want a nice smooth arc. I use a Bic ballpoint pen ink straw to shape the cables bends.

OK, so that takes care of the cable issues, lets get into the OS side of the problem. I recommend sticking with Sierra as SATA based SSD’s have issues with the new APFS file system. If there is a burning reason to go to a newer OS then go to Mojave. But be aware during the OS install process the drives file system will be migrated from HFS+ to APFS. This will make it harder to salvage the drives data if you need to later.

First you should create a OS installer USB Thumb drive following this guides:

Or, if your HDD is still workable and has the OS installer on it you can use a SATA to USB adapter like this one: StarTech - SATA to USB Cable

In either case you’ll need to use the Option (⌥) key to get to the startup manager when you restart your system so you can select the installer drive.

Reference: '''Mac startup key combinations'''

As far as your SSD: I was concerned it was one of the super thin drives so the SATA connecter was not fitting properly as the connector gets wedged against the uppercase. You may want to check the fit as I don’t know this drive some use a thinner PCB so the connector does not fit tightly.

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image

Product

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

$54.99

Was this answer helpful?

Score 2

Comments:

Still am getting the same error, did the tape, new cable, everything except try Sierra.

by

Logan - Sorry to hear it. I've put tons of Samsung 850/860 EVO drives into this series without a hitch! So if you can't get the Silicon Power Ace A55 SSD working it may have issues with its controller. Sadly, some of these cheaper SSD's have issues.

by

I tried a couple of those A55 and I was very pleased with the quality and care for smaller details. I've had no issues whatsoever with GUID or APFS. I don't know much about the company.. it's relatively new but it's among the fastest growing and number 1 in semiconductor in Taiwan. I have the impression they are not just aiming at being yet another cheap supplier.

by

@arbaman - Thats good to hear! Then that puts the issue back to the HD SATA cable!

Logan - Did you follow my instructions putting down a strip of electricians tape on the uppercase to help protect the cable? Also, did you not over bend the cable? As I pointed out you can damage it!

You need to carefully form the bends using a Bic ballpoint pen ink straw or a bamboo skewer to roll the cable around to form the arc of the bend. >> No sharp bends or folds! <<

At this point you'll need to get another cable!

by

Yes everything is working great now!!! Thank you so much!!

by

Show 1 more comment

Add a comment

Add your answer

Logan Davis will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 72

All Time: 72