Skip to main content

Model A1225 / Mid 2007 and Early 2008 / 2.4, 2.8, or 3.06 GHz Core 2 Duo processor

494 Questions View all

Continuous reboot even after replacing Logic Board

iMac 24” – early 2008 - Mac 8,1 – model A1225 – EMC 2211

S/N: QP82805M0KM

HDD – Hitachi Deskstar 1TB – Apple firmware 2007

Problem:

Apple logo – chime – progress about 50% then reboots….. and again….

Procedure:

  • Reset SMC & PRAM – no change
  • Tested memory modules individually – no change.
  • Safe-mode – freezes
  • Options – select Recovery disc – voice to select language (English) – then freezes
  • Use USB with full version ‘Mountain Lion’ – boot freezes
  • Recovery mode – reboot at 50%
  • Single-user mode – boot freezes
  • Option ‘D’ for hardware tests – boot freezes

Used USB with ‘Mountain Lion’ installation files

Get into Disk Utility and Terminal

Use ‘fsck’ utility – “HDD is ok” …. “Volume has been modified” – repeated until all ok.

Reboot – boot completed – graphics background appeared but no icons.

Icons appeared after about 15 minutes.

Repaired/verified permissions etc

Machine working - OK

 

Three days later –same problem.

All boot options tried, plus booting to Internet for recovery – all as above

Tried with USB - Full versions Mountain Lion/El Capitan – as above

Tried with USB – Lion/El Capitan installation files – as above

Single-user mode – ‘fsck’ – HDD is ok and “Volume has been modified” – repeat until error clears but it reappeared after every attempted boot.

Tried all possible Boot options, also with various usb devices.

Attempted Internet Recovery using cable-connection – no success.

Firewire connection to MacBook Pro – Target mode - reformat iMac drive.

iMac re-started - Attempt made to re-install the OS over the Internet – failure.

Re-connect Firewire – Target mode – install El Capitan – reboot iMac – reboots at 50%

 Purchase and install Logic Board – eBay UK – ‘respected’ supplier, includes test report.

Boot – then the video fails (!) – graphics for a few seconds, then black screen.

Remove GPU card – remove & replace thermal compound – reboot – Graphics ok (should have done this while changing Logic Board !)

Exactly the same as before – logo & chime then reboots itself at about 50% of the boot sequence.

Tried booting from Lion & Capitan usb’s, and Lion & Capitan installation usb’s – rebooting at 50%.

About the only thing left is the actual processor – but surely if it is a processor problem I wouldn’t get the boot logo or chime, or be able to use Target mode ?

Any advice, suggestions, or information greatly appreciated – this is driving me mental !

Note: I’m a retired electronics and IT engineer – many years repairing PCs, just over 2 years repairing Macs - have repaired 54 Macs, including 12 old iMacs …..

I hate to be beaten – but maybe this one…?

Thanks in advance - Peter

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

PC Laptop Batteries

An easy fix for a big power boost.

Shop Now

PC Laptop Batteries

An easy fix for a big power boost.

Shop Now

1 Answer

Most Helpful Answer

I suspect you have a hard drive issue here.

If this is a replacement drive did you make sure the drive was spec’ed correctly?

Keep in mind this is a SATA II (3.0 Gb/s) system so you need to get another fixed SATA II drive or an Auto Sense drive that will adjust to SATA II. Most drives today are only fixed SATA III (6.0 Gb/s).

As an example this is an auto sense drive Seagate FireCuda note the SATA interface line lists SATA II (3.0 Gb/s). If the spec sheet doesn’t list it its not likely to work reliably. As an example this WD drive is a fixed SATA III (6.0 Gb/s) speed WD Black Series and you will have problems getting to work reliably in your system.

Was this answer helpful?

Score 1

Comments:

Hi Dan

Thanks for the info.

This is the original Hitachi disk with the Apple firmware revision.

However, one post I read suggested that maybe the drive was faulty and somehow 'occupying' all the PCI bus - so I've now removed the drive and have been trying to boot into usb drives with Lion and Capitan (my 'test' drives, which work fine on usb with a Macbook).

Both these usb drives show exactly the same symptoms as the SATA drive - rebooting at 50% of the boot sequence.

I'll see if I've got a suitable 3.5 inch desktop drive and try again.

Any other ideas are really welcome !

Thanks

Peter

by

Not sure where you read about the HDD using more of the PCI bus. The SATA interface uses only one PCI lane and thats it! From the South Bridge chip.

So this is the original drive then I'm thinking the logic board is failing! These older systems with dual support chips (North & South Bridge) often encounter issues with the bus side chip (South Bridge) I've often needed to re-solder it for a cold joint or two. Look for the schematics for the system on the internet search for the board number: 820-2301 or drawing number: 051-7484.

by

Thanks, Dan.

My original thinking was ‘Logic Board’, so I purchased a re-conditioned one (the one I’m discussing in this thread) - so what are the chances of two boards showing the same fault ?

As mentioned, I don’t see how it can be the processor. However, I find that the boot sequence seems mainly to involve the VRam - what would be the chances there ?

Planning now to reinstall the original Logic Board and start again….

Incidentally, I hooked the original drive to a USB3 adapter and used it to boot an old Macbook Pro - no problems or errors at all, so that’s another box ticked….

My thanks again. Dan

by

Add a comment

Add your answer

Peter Owen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 35