Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1371 Questions View all

Laptop does not turn on, charges battery when plugged in..

All right.. Well I have a Santa Rosa model 13-inch Macbook from late 2007 I believe..

The symptoms: A couple of weeks ago the trackpad and keyboard began function only intermittently; normally the symptoms would resolve itself after a restart or two. A few days ago, it got so bad that both the trackpad and keyboard worked rarely, and all the computer could do was power itself on. I opened the laptop to check the flex cable, which from what I understand sends signals from the keyboard/trackpad to the logic board. I don't *believe* I damaged the part, but all I did was take the flex cable out for a minute or two, check it for visible physical flaws (I found none), and then reinsert the cable and close the Macbook.

Now, after closing the laptop and making sure everything was in place correctly, the Macbook power button no longer turns on the computer when I press it. I plug the magsafe cable in, and the corresponding light turns green, then orange, as though the battery were working properly. However as I said before, the computer does not turn on when I press the power button.

My question: If I damaged the flex cable, is that the likely cause that my laptop no longer turns on? Any advice/help would be appreciated. I've actually opened up macbooks before and never had a problem, so I have no clue what's going on here.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Guys: Thanks so much for your replies; I just tried to turn the computer on again, and it now powers up just fine but both the keyboard and trackpad are completely dead. At this point I have no doubt that the flex cable is bad and must be replaced - in fact I've already ordered a replacement part.

FWIW, I have no clue why the Macbook wouldn't power on for a day.. But one detail I forgot to mention is that while I had the case open, I decided to clean the logic board completely using a canister of pressurized air to knock off all the dust that had accumulated inside over time. I noticed sometimes the pressurized air shoots a small amount of water or humidity, which got onto the board in some places.

Could it be that the humidity was causing a malfunction, and that the logic board couldn't power on until all of that had dried up? It stopped functioning for a day after simply opening it up, checking the flex cable, and using pressurized air to clean it. Your thoughts would be appreciated!

Thanks,

Andres

by

Add a comment

1 Answer

Chosen Solution

You've diagnosed the problem well. Try reseating the cable first. If you can get it to power up, try using an external keyboard. Check to see if your battery is swelling and putting pressure on the bottom of the trackpad. Have you spilled anything on it?

Was this answer helpful?

Score 3

Comments:

I didn't spill anything really.. But I did connect a USB keyboard and mouse, and the computer functioned perfectly afterward. Hence it must be the flex cable.

by

Add a comment

Add your answer

Andres will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 559