Skip to main content

Fix Your Stuff

Right to Repair

Parts & Tools

Google's 2nd-generation Pixel XL sports a 6-inch P-OLED display with rounded corners. Available in 64 and 128 GB storage configurations, and in two colors: Just Black and Black & White. Released October 19, 2017.

58 Questions View all

4G Randomly disconnecting after screen and charging port replacement

Hey, after replacing the screen and charging port on my Pixel 2 XL my cellular data has kept disconnecting. Did i do something wrong? Do i need to open to phone again to fix or buy new parts? Here is a screenshot from the status bar when it disconnects

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

2 Answers

Most Helpful Answer

You might want to open the phone again and try reconnecting the connector for the new charging port. Also try rebooting it a few times. The Turn off and back on thing is very old fashion but sometimes it works! Best of luck!!

Was this answer helpful?

Score 1
Add a comment

I had a similar issue with my Galaxy S4 a few years back, when I first started getting interested in repairs. I had accidentally snapped the head off the antenna so it obviously wasn’t connected. I only realized it when my signal was crap and I had to buy a new antenna. It may also be due to the charging port connector as Ian Shalongo said.

Block Image

Before you go ripping your phone apart though, you should try a few things…

Try rebooting the phone.

Check for any updates. Many Pixel 2 owners had signal problems that needed an update to be fixed.

Try basic trouble shooting steps like popping the SIM out and back in, resetting network settings, etc. There is a really good guide for

https://thedroidguy.com/2019/03/how-to-f...

Good luck and God Bless

Was this answer helpful?

Score 0

Comments:

I have tried the basic steps like taking out the sim and rebooting it multiple times and even done a factory reset on the device without any luck. I think im just going to buy a new display adhesive and rip the phone open to see what i did wrong.

by

Did you reconnect both ends of the antenna wire along the right side of the phone?

by

Add a comment

Add your answer

Mico Hautaluoma will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 30