Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

770 Questions View all

Any problems with large hard drives and the 13" MBP?

I recently installed a large hard drive in my 13" unibody MacBook Pro Mid-2009. The drive I put in is a Western Digital Scorpio Black 750 GB. I am having all manner of difficulty with my machine now, where it is doing random weird things. Like, once it would not let me copy any files, even if I logged in as an admin. Another time I shut down the machine as normal (absolutely no issues whatsoever, completely normal shutdown like I've done countless times before), but when I came back to it several hours later, it refused to boot (gray screen with a flashing question mark). I booted from an OS X install DVD and was able to repair my disk using disk utility (it came up with some filesystem errors) and the system booted again. Etc.

In attempting to resolve these issues I found some talk online where other people are having problems with drives greater than 500 GB. Some of the messages mentioned my drive (the WD Scorpio Black) specifically, so I tried a different large drive (Hitachi Travelstar 750 GB). And since the last time I tried this I had cloned my system using SuperDuper, I thought maybe that was the problem, so this time around I instead did a complete OS install from scratch. The system performs much better now (seems faster, etc.) AND it has been much more stable. Until now. Twice in the past few weeks the machine has randomly and spontaneously logged me out. I have watched this happen once - I had left the machine idle, doing literally nothing, no programs other than Finder and a few menu bar extras open, and then suddenly the system goes back to the login screen. When I log back in again all of my startup items are no longer set to start up, so I have to go through and re-add them to the Login Items list in system preferences). I looked up this issue and see that though rare it does happen to a fair number of people. The funny thing is that until now this has never happened to me.

Anyway my point here is this: does anyone know of any problems between my 13" unibody MBP mid-2009, and large (>500GB) hard drives? Or is there some other issue at work here? Or am I just being paranoid over nothing? I don't want to, for example, be in the middle of editing something in Final Cut or GarageBand and have the machine suddenly log me out and lose my work, which is what concerns me here.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

If it were mine, I'd reformat the drive and use the "write zeros" option to map out any possible bad blocks.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

Hi, Checking MacTracker I find the largest drive from Apple was 500 MB but that should not preclude your using your current drive. The only thing I did find is a firmware update--EFI firmware update 1.7. You might want to check and see what level firmware you have--it MAY help with your problem but there are no guarantees. If you do decide to update read the instructions carefully-- a firmware update can brick a logic board. The easy answer is to install a 500 GB drive and put your 750 GB in an external case and download your finished edits to it to insure room on the system drive. Good luck. Anyone with a better answer please speak up.

Was this answer helpful?

Score 1
Add a comment

Sorry for the late reply, but it's not the size of the drive. I've had a 750GB drive in my mid-2009 MBP for 1.5 years now without issue. The behavior you're describing is most likely due to a faulty Hard Drive Cable. The first story at the bottom of the iFixit page for this cable in question described a fellow who "found this model notorious for the board drive cable going bad." Dozens and dozens of others have experienced almost identical behavior — in Flashing question mark on startup, — in addition to this forum on Apple Discussions, as well as this one. RECOMMENDATION: Do the most important test first: Remove the drive and see if it functions — either in another unit or as an external drive, with a SATA to USB interface or similar. If it does, then erasing the hard drive and/or reformatting it will not only prove ineffective, but unnecessary. Just replace the hard drive cable (in my case it was this one) and you should be all set.

Was this answer helpful?

Score 0
Add a comment

Add your answer

dburr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,073