Skip to main content

Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

535 Questions View all

Disable dgpu on MacBook Pro late 2011

Hi,

I’m having a problem with my MacBook Pro 17” 2011 with faulty GPU.

I tried to set the NVRAM variable and delete the AMDRadeaonX3000.kext file, the procedure worked well on my Early 2011 MacBook Pro but it did not work well on the late 2011.

When I set the NVRAM variable the late 2011 screen go black and stays black until I reset the PRAM settings (ctrl+cmd+p+r), so cannot disable the dedicated GPU.

BTW I have disabled the GPU of many MacBook Pro’s as described in Mac Rumors and the procedure worked flawlessly. However with this particular Mac the screen goes black when I enter the single user mode and set the NVRAM variable:

NVRAM fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Do you know where the problem can come from? Why my screen goes black when I set the NVRAM variable to Intergraded GPU (%01%00%00%00)

Can anyone help me with that? I did not find anything about on the net

Thanks

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

What is your exact model and the screen type? Review this listing MacBookPro8,2

by

Well

the mac get stuck on the apple logo while loading… same issue that happens on the 15”

thanks

by

Are you able to boot up in Target Disk mode? Hold the T key do you see the FireWire/Thunderbolt port icon?

by

Add a comment

iPhone Battery Fix Kits

Only $29.99

Buy Now

iPhone Battery Fix Kits

Only $29.99

Buy Now

1 Answer

The approach you are applying is not workable on the 17” models as they are using a different logic design than the 15” models.

The 17” models also don’t have the same board layout. Unlike the 15” models the GPU is located away from the CPU so overheating is less of a risk.

Was this answer helpful?

Score 0

Comments:

I already applied it on early 2011 17 inch model and it worked perfectly

by

I've not personally seen a dedicated GPU failure on the 2011 models I have a 17" model which I use for photo editing and its still ticking! I've seen issues with the heat pipes as well as the fans are you so sure your GPU has failed here?

I've seen lots of issues with the older Core 2 Duo models with the PCH chip.

I think you really need find the schematics and board view drawings, roll up your sleeves and debug the logic properly.

by

Add a comment

Add your answer

Charbel Bouery will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 10

All Time: 66