Skip to main content

ZTE Grand S II features a 5.50-inch 1080x1920 display powered by a 2.2 GHz processor alongside 2 GB RAM.

9 Questions View all

Can't Open List of all Apps on Device

This might be an odd question, but I’ve been experiencing this issue since I’ve had the phone and I haven’t been able to find an answer for it online. Whenever I hit the onscreen “all apps” button that takes you to a list of all apps on the phone, I’m always presented with a really zoomed-in version of the list that shows two apps out of the entire list. I’ve attached a picture of what I mean.

Block Image

As you can see, Discord and Docs are both visible, and I can still open them, but I can’t access any other apps from this screen. I can’t figure out how to stop it from doing this. It seems to be random when this issue triggers, and when it stops again. Any fix that I think I find (hitting the power button, closing all apps, pressing and holding the app list button) fails to consistently solve the problem. I’m out of ideas and I still have no clue what’s causing this. Any suggestions would be greatly appreciated.


Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi @brunbo1 ,

Have you tried starting the phone in safe mode to see if the problem still occurs?

To enter safe mode, with the phone on, long press your Power button. Then long press on the Power off option. You will then be asked to reboot into safe mode.

To exit safe mode just turn off the phone in the normal manner and then turn on the phone.

If it works OK in safe mode then a downloaded app is the cause of the problem. The trick is to find out which one. You’ll need to uninstall each downloaded app, one by one, and test the phone in “normal mode” between each uninstall to see if the problem is still there or not. Once it stops then the last downloaded app that was uninstalled is the culprit.

If it still fails when in safe mode, try resetting the phone and check if it still happens.

Before resetting the phone using the phone’s factory restore feature, ensure that you backup the phone using the phone’s backup feature as a factory restore will erase all your data and downloaded apps.

Once the phone has been reset to factory default, see if the problem still occurs.

If it still occurs, you may have a hardware problem with the phone.

If it doesn’t occur, restore the phone from the backup that you made earlier, using the phone’s restore feature.

Once it has been restored to what it was, check if the problem still occurs.

If it still doesn’t occur then the “reset” has resolved the problem

Was this answer helpful?

Score 3

1 Comment:


Thank you for the helpful suggestions. I have tried safe mode and unfortunately, that didn't solve the problem. I'm currently backing up my phone for a factory reset. Unless it's a fairly common hardware issue, I don't think it's a physical cause, as my sister has the same model of phone and she's experienced this same issue in the past.


Add a comment

Add your answer

Bryan Purves will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 88