An e-cigarette vaporizer is reusable alternative to traditional smoking.

78 Questions View all

Smok x-priv bricked, turns on to show smok logo and cuts out

hi all i have a Smok x-priv mod donated from a friend it started with a short in the atomizer error so i cleaned the port for the tank and checked the batteries etc, i then plugged it into my laptop to charge, as soon as i plugged it in it went to a black screen and would not turn on, the only way i can get any activity is by taking out the batteries and putting them back in, this brings up the smok logo and then it shuts down, does anyone have the firmware for this device so i may try reinstalling it, i have tried the method mentioned in another post saying to hold down all buttons without batteries, and to connect to a pc then put the batteries in but this did nothing

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

also any info on how to remove the firmware from my bricked device would be appreciated thanks peeps, cant seem to find it when i connect it to my pc

by

Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

2 Answers

Sounds like it’s just not charged. Have you tried changing the batteries for known good fully charged ones?

Was this answer helpful?

Score 0
Add a comment

I just had to run to my local vape shop as i was having the same issue it took me and the owner a few minutes to figure it out.

If you know how the locking on this device works you have to do that after you put in the batteries. After the smok logo disappears just tap the firing button five times not to fast or slow and then wait a second it should show the smok logo again and then then screen will show all the info and be ready to fire. it’s not software it’s user error and man you’re not alone.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Tom Norc will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 62

Past 30 Days: 211

All Time: 1,017