Skip to main content

Released September 16, 2016. Model 1660, 1778 Available as GSM or CDMA / 32, 128 or 256 GB / Rose gold, gold, silver, black, and jet black.

1332 Questions View all

Replaced dock connector; cellular not working

I replaced yesterday my dock connector of my iPhone 7. After I installed everyting back together and started the phone, the celullar wasn’t working anymore. It says: No Service. I removed the dock connector, started the phone without any dock connector and the cellular works fine. Is the antenna on the dock connector broken?

Who could help me?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

To be clear: You disconnected the two cellular antennas from the Lightning port assembly and you DO have cellular service, but when those two antenna are connected you DO NOT have service?

by

I only disconnected the antenna cable from the charging port. The cable from the speaker antenna was already disconnected for the testing. So, without the two antenna cables it works but with the cable plugged from the charging port it does not work.

by

Can you post pictures of the connector? Also where are you getting your parts from? I've had this issue before and it was due to a faulty part.

by

Yeah looks like a faulty part. Basically the antenna on the charging port has a bad connection.

by

@toreskey @benjamen50 I got a new dock connector and still no service. If I unplug the flex from the dock, I got 4G (cellular). If i install the flex from the dock, no service...

by

Add a comment

1 Answer

Chosen Solution

Replaced the dock again and now it is working. Seems like the new dock was faulty.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Uas will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 7

All Time: 102