Skip to main content

Repair and disassembly guides and support for dish washing appliances.

713 Questions View all

Dishwasher power switches off after a few seconds or once door is open

Whirlpool WDT970SAHZ

Just had a whirlpool dishwasher installed (this is the second in two weeks), once installed and connected to power the lights will switch on for a few seconds then switch off. Opening the door to reveal the buttons switches the lights off also. The buttons remain unresponsive and cause no reaction. The appliance has been tested plugged into several outlets around the house using an extension cord.

We don’t think it’s the wiring, as the last dishwasher worked perfectly, but can’t believe the same problem has happened with two of the same dishwashers. Any one have any insights or tests we can try?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

I suspect a power supply issue. My first guess is that the wall receptacle is at fault.

Could be reverse polarity:

Here’s a video on how to test and fix that:

https://www.youtube.com/watch?v=G2P67ZXE...

Here’s what it is:

https://diy.stackexchange.com/questions/...

Was this answer helpful?

Score 1

2 Comments:

@mayer thanks for your answer. Just tested it out and it doesn't seem to have fixed the problem.

by

I’ve had the same dishwasher since 2011 has this been resolved? I’m having the same issue! It’s worked perfectly for years but now this

by

Add a comment

We had a similar problem during the last couple of months which is, it would run a few seconds and then cease. We’d have to re-run it 4-5 times and hopefully wait for it to begin its cycle. Ours is an 8 yr old Whirlpool, Gold Series. I did come across a few blogs and decided to try out one before I sourced a local technician viz. using a small screw-driver (watch repair types) and inserted it into the latch slot located on the inner top side of the door and it seemed to release a teeny plastic lever as well as lift out some accumulated debris (the blog states one hears a ‘click’ sound!!!). For added measure we cleaned the filter and closed the door whereupon we heard a distinct ‘clap’ sound (one which we’d never heard before) and …..WALLAH, it started right away. Apparently, the hook located on the main body opposite the latch wasn’t engaging, possibly as that teeny lever had shifted to the side and probably that is why the unit wasn’t able to initiate into motion. But, boy are we glad..****** :-)

Was this answer helpful?

Score 0
Add a comment

Add your answer

Tom Groom will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 14

Past 30 Days: 51

All Time: 3,725