Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

151 Questions View all

Optical Drive spins upon boot up but never recognizes disc in it.

I was given this PB with the knowledge that the optical drive 'was not working'. I have a iBook G4 933Mhz PPC (A1055) that is on its way out. I found that its optical drive is the same one in the PB... so... I have swapped the optical drives.

Booted up the PB with the Optical Drive from the iBook and put in an OSX disc... after spinning a bit and sounding like it was going to read it, the drive spun down with no desktop icon. I checked Disc Utility and it does not show on that.

Now I looked at the Optical Drive I pulled from the PB... I saw that a disc was stuck in it. I pulled that out (an Apple Care protection plan disc) and then loaded that drive into the iBook.

Power up the iBook and put in a disc... it works great!

Any ideas why the optical drive will not work in the PB? It is running 10.5.8 which hangs up when trying to use... but that is another issue.

More details... When I look at system profiler, the 'Disc Burning', 'Parallel SCSI', 'SAS' or 'Serial ATA' show any devices. Should it be showing on one of these?

Help!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Looking at my iBook system profiler, I see the following under 'Disc Burning'

MATSHITA DVD-R UJ-815:

Firmware Revision: DWDB

Interconnect: ATAPI

Burn Support: Yes (Apple Shipping Drive)

Cache: 2048 KB

Reads DVD: Yes

CD-Write: -R, -RW

DVD-Write: -R, -RW

Write Strategies: CD-TAO, CD-SAO, DVD-DAO

Media: Insert media and refresh to show available burn speeds

This is the one that was in the PB. An equivalent one purchased from iFixit years back is now in the PB.

by

Any help here folks?

by

How much RAM do you have in that iBook?

by

The PowerBook has 1GB RAM (2 512MB chips)

by

Add a comment

1 Answer

Chosen Solution

First I would carefully inspect and clean the connections between the optical drive and the logic board. If it still refused to function I would try using an external connection for the Optical drive. If it works there you may have a logic board problem--if not I would run disk repair. If disk repair failed I would reinstall the operating system. Try these steps and let us know how it comes out. Good luck.

Was this answer helpful?

Score 3

Comments:

Disconnect the cables and check the cable ends and sockets for dirt and/or corrosion. Use a external case or a testing cable to run the Optical drive out side the case. Fir test purposes either USB or Firewire will do but if you buy an external case get a firewire version so you can boot from it.

http://eshop.macsales.com/item/NewerTech...

by

Can you expound on the first two steps?

What is the best way to clean the connections? Blow them out with can of air or some other way?

External connection...with this internal drive? How do I accomplish this? An adapter of some sort?

Disc repair is the tricky one with the drive not working. I think I tried this with starting the PB in target mode. I have tried so many things, I cannot remember :-) I will try it again.

This install of 10.5.8 is a new install I did with target mode. It was running an older version when I first got it. I updated to see if it would fix it.

Thanks...stay tuned.

by

Well started up the PD in target mode. I have Disk Warrior on my MacBook Pro which can see the PB drive. I can run a repair which found minor things and fixed them. It will not rebuild the directory due to a message: ------------

DiskWarrior cannot currently be run from this disc because Mac OS X ignores ownership of new discs by default. Please restart from this DiscWarrior disc (I try... but it just spins and never fully boots up) or follow the instructions below.--------

In short... 'get info' on app, click ownership and Permissions, uncheck "ignore ownership on this volume" Then eject the disc and reinsert. (problem here is that option is not available when I 'get info')----------

very frustrated this is not working out.

by

Ok... Tried to boot up from the DiscWarrior CD one more time... After about 15 minutes it came up. I can inspect the local MBP drive, but the target mode drive is not showing yet. Running through the inspection od the local drive then we'll see what I get on the PB...

by

PB drive checks out fine. I rebooted out of target mode and the issue is still there.

If you can please expound on the first two items you suggested... thanks!

by

Show 1 more comment

Add a comment

Add your answer

rogerhall will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 916