Skip to main content

1.5 Core Solo, 1.66 or 1.83 Core Duo, or 1.83 or 2 GHz Core 2 Duo processor. This covers the first Intel-based Mac Mini models from Early 2006 to Mid 2007.

141 Questions View all

Mac mini stuck on apple logo screen

I am hoping that someone can assist, and before I get slammed - Yes, I know this baby is OLD. I have an A1176 Mac Mini. I used it for quite some time. I had dual boot Snow Leopard and Windows 7 installation.

I put it away for a while - as work changed, had no time to play on it. I took it off the shelf where it had say for 3+ years. I was fully working when I put it there.

First thing I noticed, when I hooked it up with the DVI >> VGA adapter which had always worked, I would get no image. The monitor constantly had [NO SIGNAL] message. The monitor works just fine with the Windows Server I use it on.

I removed the adapter and attached the DVI cable to the same monitor and back of the Mac, and I got a grey screen with an Apple. I attempted to boot into Recovery Mode, and while I would get the option to boot into Recovery or OS-X - Neither would load. They would start, and I would get the folder with flashing ? Which I know is bad. I took the HDD out - as it had given me problems before. I attached to another PC with a USB adapter and ran a HW test. The SMART test failed, and it also gave multiple errors and even occasionally make a clicking noise.


I wanted to put an SSD in there anyway. I bought a brand new Samsung EVO 750 120GB drive, and put it in. The system seemed to like it. I go no errors on booting it up. Got the normal TAAAH! sound.

Now here is where the issues lie - I knew I had to reload the OS. I have a USB Drive which I have used for years to reload this machine or my MacBook which died 2+ years ago. It was the Snow Leopard installation (which had been on this machine). I booted, held the Option Key, saw the drive and clicked it. It began - what I felt was installation. 10 mins later, it was still on the Grey Apple screen... No whirligig moving - only the Apple. I said....****. Did a PRAM RESET, got the TAAAH!, waited - got 2nd TAAAH! and let go of the keys. Just so that it is known, all keys on the keyboard appeared to be fine. Caps Lock would light if touched. The PRAM reset did nothing.

I next tried the DIAGNOSTICS, it never does anything. It will eventually go the same FOLDER with ? on the screen. Have tried the COMMAND + R, and the SHIFT + COMMAND + R, nothing works there. I’ve tried the verbose mode, and only once got it to boot there. I goes through some stuff on one screen - clears screen and gives another list of data about 1/3 of the screen and stops. I have pictures of this screen. I do not see anything which jumps out as error.

It had 2x2GB DDR2 667 DIMMS which have always worked, and it has the 64bit CPU. I have re-seated both of those, made sure all the connectors are secure and all wires from the HDD swap. Still nada. Just to make sure the HDD was not the issue, I put in another old 80GB SATA drive. Same results when trying to install. Hangs on GREY SCREEN - will sit there for hour if I let it. I also attached the new SSD to my windows PC with the USB adapter, and it is seen, will let me format it for MBR or GPT. I used TRANSMAC and told it to format the HDD for MAC USE. It works. Still nothing when put back into the MAC.

I dug out my old install DVD for Leopard, and put into the drive. It makes all kinds of racket and then spits it out. I opened up the DVD and made sure the lens was clean and freely moving. Tried again - still spits it out. I attached an external DVD to the machine, booted with OPTION, finds the DVD chose to install. DVD flashes 3-4 minutes, and the same grey apple screen appears and never goes anywhere.

I took one of the 2GB DIMMS out, and tried again...SAME. Swapped the DIMMs and again... SAME. I tried the SMC clear process... both methods. Still nothing.

I cannot get SAFE MODE to work - as there is no OS installed.

I’m now at wits end. I would love to get this running again, but have run out of ideas. Looking for help as what else to try.

Thanks a million in advance,

Update (11/10/2018)

I was able to get the MAC MINI A1176 to boot into VERBOSE mode - here is a picture of the screen.

Block Image

Answer this question I have this problem too

Is this a good question?

Score 3

By the way, we don't do slamming here ;-}

I have 3 of these A1176 Mac minis and I LOVE them all. .

Onto the topic that these Mac minis are older, I actually encourage people to buy older Apple products as they are less prone to breakdowns and they are easy to repair.


@Aaron - that is good to hear. I was on another forum about a year ago when I posted some questions about upgrading this A1176, and I had no less than 3 people tell me "Get rid of it, not worth is old as dirt." Needless to say, a Core 2 Duo (and I have heard some people have gotten a Core 2 Quad to work in them) is not a shy peice of equipment. Granted 4GB of RAM is not really fair for that must CPU - but at least it is 4 cores, and 64-bit.

I hope I can get this baby to work again. It was a nice box before the HDD died. I am sure with the Q2D 2+ GHz CPU, 4GB RAM and a SSD it is gonna fly.


Whoever told you that your Mac mini was worthless is a disgrace to this forum, I'll say.

I mainly use those Mac minis I have for storage and disk formatting. I can't really browse modern web pages because they don't quite load correctly. Other then that these machines are definitely great for running older versions of OS X and DVD burning too.


Add a comment

2 Answers

Most Helpful Answer

Sounds like you forgot to format the drive GUID and MAC OS X journaled with Disk Utilities. Use your Snow Leopard disk. Boot from it holding down the C key. Go to the installation, second page & the pull down menu will appear, Go to Disk Utilities, format the drive GUID and Mac OS X extended journaled. Now close Utilities out and continue with the system installation.

The EVO 750 supports SATA 6Gb/s interface; however, it is backwards compatible with SATA 3Gb/s and SATA 1.5Gb/s.

Was this answer helpful?

Score 5


@mayer - I don't think her's even able to get to Disk Utilities yet. I think he needs to replace the PRAM battery before he can get to the next step in getting this baby working.


@danj If he can get to the flashing folder, he should be able to boot from the 10.6 disk and get to Utilities.


Thanks for both of your I stated, I have tried everything. I have RESET the PRAM with keys down option on boot. I put a brand new Coin Batt in it as well. If I do not do anything and just boot it...I get the Flashing Folder. If I boot with the OPT+C, and I have the EXT DVD connected - I get the option to install it - but it does not show the HDD. The HDD was formatted with TRANS MAC - as I first though that was the issue

BooteOPT+C, choose OSX from EXT DVD after about 2 mins I get the GREY APPLE, and the DVD light is flashing like it is reading the disc. It was burned from a .DMG I got from APPLE - about a year ago from this very machine-burned with this EXT DVD drive, and then tested. It has been used to reload MACs at the office before donating them

It makes the TAAAH! and goes to the flashing folder that the MotherBoard is still good. The DVD Drive spits out anything you put into it, even Audio CD. So I have given up on that all together.

Any other ideas?


The external drive may work fine AFTER you have the drivers enacted. Macs do not play well with external third party optical drives.

At this point it sounds like you need a good internal optical drive.

Alternative is to find a friend with a Mac, use a SATA to USB adapter, then format GUID and install a system.


Mayer --- Thank You.

I also have a USB Flash Drive with 10.6 on it. I will also boot from that (OPT+C) and give me the option to see the OS X Snow Leopard install media.

I do have a USB to SATA adapter, and a very old MAC - which may let me format the HDD as GUID. I will give that a try. I will have to dig the old MAC out -- it is an old PowerPC Mac with Leopard on it. I need to try and sell that thing. I had the 23" Crystal display and all - very nice - I upgraded it as far as it could go. DVD Burner and the works. The problem with the display, is that it is powered by the video card. It is a GREAT MONITOR though, and looks brand new.


Show 11 more comments

Add a comment

As you had the system on the shelf for a few years I’m sure the PRAM battery is long since dead and you will need to replace it before you can go forward here.

Here’s the IFIXIT guide you’ll need to follow: Mac mini Model A1176 PRAM Battery Replacement

Was this answer helpful?

Score 1

1 Comment:

Battery was replaced - as I thought that was issue. Brand new Coin Cell.


Add a comment

Add your answer

Curtis E Norris Jr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 1,311