Skip to main content

Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

462 Questions View all

Check me please: Dead...no start, no response, other than charge light

Hi there,

I suspect I know the answer, but I’d really appreciate “a second set of eyes” on my problem.

15” Macbook Pro 2.4, Late 2008 (Unibody)…does not start.

• using the correct 85w power supply, tested working

• battery is only 6 months old

• tried resetting the SMC several times

• tried starting with and without the battery.

• tried the “rm batt while magsafe connected, rm magsafe,hold start 15s+, plug magsafe, plug battery” method

• tried with and without ram

• tried starting using the power pads on the logic board

• with the battery connected, the charger shows an orange (charging) light

• with the battery disconnected the charger shows a green (power) light

But otherwise, no response whatsoever.

Is there anything that could be causing the problem other than a faulty logic board?

Thanks much!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

1 Answer

Chosen Solution

If you don’t even get the fans spinning, answer is unfortunately no, nothing besides logic board failure most probably. You can try disconnecting one by one from the logic board all components, superdrive, screen, etc, just not to let anything untried, only to rule out an internally shorted component. It won’t take much time and it’s the only reasonable thing to do left.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Drew Mouton will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 31