Skip to main content

Robot vacuum manufactured by Neato Robotics

4 Questions View all

Error 3000 - Neato does not start moving

My Neato D85 has been working well. About 10 days ago, I changed its battery. It was working well until now. It gets ready to start but then stops and give me the message “press OK to continue (3000)”. I press OK and it tries to get ready but again stops and sends the same message.

What did I do? I cleaned its laser area with a cotton tip and pressured air too. Nothing. The disk moves though.

Any suggestions on what could happen but mainly how to fix it?

Thanks!

Answer this question I have this problem too

Is this a good question?

Score 4
Add a comment

2 Answers

Most Helpful Answer

Hi,

I had this problem with a D85 Botvac. Contacted Neato support and they first informed me that my unit was (literally) 1 month out of warranty (so no surprise there) then proceeded to give me some crazy minimum price for them to fix this. As I had previously opened this baby up due to a broken drive belt for the side brush, which can be replaced with any suitable sized O-Ring, I decided to take a look.

After poking around and measuring voltage and continuity here-and-there, I discovered that the problem was located with the actual on/off master-switch (or battery isolation switch) itself which had an intermittent fault. Don’t get me wrong, a dying battery WILL give you this fault also, but if you replace that and still have no luck then you need to either clean or replace that switch (cost is about €0,50 in any decent electronics store).

I managed to initially get mine working by shooting some compressed air into the switch then a little contact cleaner spray (the type that evaporates - wouldn’t recommend WD40 or anything similar as the switch is pretty exposed to dust flying around inside). That lasted about a couple of months until the next incident so I just replaced the switch - three easy desolder/solder joints and as good as new - been running 100% since then.

Hope this helps anyone out there with this annoying problem.

Was this answer helpful?

Score 2
Add a comment

I have the same error. My Neato has been replaced for this issue before.

Now, almost a year later the same error starts occurring. The laser starts spinning, but stops after a few seconds because the desired speed (rpm) is not reached. This can be caused by worn bearings / dirt / bad battery (too low voltage) etc.

Was this answer helpful?

Score 1

2 Comments:

or a worn driving belt (for the laser)

by

Or a bad lidar drive motor

by

Add a comment

Add your answer

divine.cricket will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 21

All Time: 2,132