Why does the unit fail to respond to touch?

Why does the unit no longer recognise that I am trying to activate functions? It has worked fine but now I can't get it to acknowledge my attempts to "slide to unlock".

Is it likely to be a sensor problem?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Geoff, it is possible that your digitizer quit on you. Did anything happen to your iPod? any recent updates or anything that happened just before it quit? Have you tried to reset your Touch? To reset your iPod Touch, press and hold the Sleep/Wake button and the Home button at the same time for at least ten seconds (or longer) until the LCD display will clear and the Apple logo appears. Once the logo appears it is reset. Let us know how it is going. Good Luck

iPod Touch 1st Generation Front Panel Replacement

Was this answer helpful?

Score 0
Add a comment

Hi Oldturkey03,

Thank you for your prompt and informative reply.

After sending my request, I had my Ipod connected to the computer and I tried an option of reverting to original settings in "Sync" mode. This fixed the problem. It also deleted all the music and podcasts, but that was no real drama as I just reloaded everything.

Thanks again from a first time user.

Geoff

Was this answer helpful?

Score 0

Comments:

Geoff, thank you for accepting my answer. Great that you got it working again. Those devices can be tough to get around, but once they work they are great. Good Luck to you and your iPod.

by

Add a comment

Add your answer

Geoff will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 766