Skip to main content

Hitachi LE43A509 turns on, but has no picture

So a couple of days ago my tv stopped showing anything but a black screen. When I press the power button it seems to turn on (backlight works and the power indicator turn blue) but nothing shows up on the screen.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

My tv I don’t have Signal

by

Hi @ Frackr Michael,

Can you see the TV menu options screens OK?

Have you tried connecting the signal source to a different input or input type on the TV?

What have you tried?

by

Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

1 Answer

Most Helpful Answer

Hi @gonzon06 ,

Try a Power reset:

Switch off the TV, switch off the TV power outlet and disconnect the TV power cable from the outlet.

Press and hold the TV’s Power button for 30 seconds to drain any residual power from the TV then release the button.

Reconnect the TV power cable to the power outlet and switch on the outlet.

Turn on the TV in the normal manner and check if it turns on OK.

According to the service manual if it doesn’t turn on after performing a power reset it may either be a faulty mainboard or a bad display panel.

(To download the service manual, when the sentence below the Document preview box changes from This file is downloadable free of charge: ...processing... to This file is downloadable free of charge: Download click on Download as this is the link. Be patient it takes a little while to find the file)

Here’s an image, taken from p.11 of the manual showing the Troubleshooting flowchart applicable to your particular problem. I’ve highlighted the path in green.

Block Image

(click on image to enlarge for better viewing).

Hopefully this is of some help.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Steve will be eternally grateful.
View Statistics:

Past 24 Hours: 44

Past 7 Days: 172

Past 30 Days: 908

All Time: 2,390