Skip to main content

Fix Your Stuff

Right to Repair


Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1623 Questions View all

You may not install this volume because the computer is missing a firm

Mojave installs just fine on an external drive, the when put into the machine it destroys the drive to the point of being unable to even format it or even see it.

When trying to install internally I get the popup,

“You may not install this volume because the computer is missing a firmware partition.”

If I install a partition with Disk Utilities I get the same thing.

If I run into someone who helped write High Sierra or Mojave and included these obstacles to make older Macs obsolete, is it Justifiable Homicide if I strangle them with my bare hands? Or should,I just carve an Apple logo into their foreheads?

I have five machines MBP 2011-12 on my bench right now that were upgraded with Seagate SSHD drives. All are now non-functioning because of High Sierra updates and I can’t fix them. I’ve already replaced about a dozen drives out of my pocket because of this. I sent emails out to all my customers with SSHD drives not to upgrade a couple of months ago.


OK I tried just a standard Apple 500 GB drive. Formatted it externally. Put the drive in the MBP 13” 2012 non-retina machine and get the same “You may not install this volume because the computer is missing a firmware partition.” So Pulled it wiped it again and put it in the machine. Did an internet recovery and install the original Mavericks. Dropped on downloads od El Capitan, Sierra, High Sierra, and Mojave. Will install them all in order until I get a failure and report back. @ajcooke01 @danj

Still think Tim Cook would look good to me with that Apple carved into him.


El Capitan installed, no problems but noted no firmware updates. Going for Sierra now.

Sierra OK, doing the updates now.

UPDATE 10/5/18

Took the standard Apple branded Seagate MX 500GB all the way to Mojave and it’s running OK.

Now I tried a clean install of Mojave on a Seagate 500 GB SSHD older model. and all went slick. Did Migration. Now when I try to start, it takes forever for the loading progress bar to complete, especially the last quarter of an inch and NO JOY. Cannot get it to fully boot. Will be trying various cures today. This is really depressing as I have installed a couple of hundred Seagate SSHDs both the FireCudas and the older models. When trying to boot in Safe Mode, I get the Apple logo flash on, then a circle with a line through it, then it starts to load, get 1/3 of the way and the machine shuts down.

UPDATE 10/6/18

I put the stand drive back in internally and it booted just fine.

Hooked up the SSHD externally and repair attempts failed. It did show up titled as APFS Media. So the software install has put that APSF on again. After four attempts I was able to reformat it OS X Mac Extended. @danj, not sure what to try now except to take it down to Sierra. Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 4


@mayer settle down there good sir, just replace their toothpaste with thermal paste. ;-)

Have you tried the APFS formatting scheme? Have you tried installing the Mojave installer app onto an internal SSD/HDD with High Sierra on it and then installing it via the installer app?

Also, are you sure that this HDD/SSD works 100%?


Simply download Carbon Copy Cloner. First 30 days its free. Use CCC to create a firmware partition on the target OS disk. Then install Mojave!!! Easy. See how it pays to know the right people. Regards, Barron Hall. Chief Wealth Creation Mentor for


Add a comment

3 Answers

Chosen Solution

@mayer - Hold on here! You’ve thrown the baby out with the bath water!

Lets back up….

Apple applies EFI updates with EACH OS release! So the root issue here is the system does not have the REQUIRED firmware to work.

We hit this already with HFS+ to APFS with High Sierra. Where people would have updated their system and then they needed to replace the logic board and BAM! dead system as the drive was updated but the new logic board still had the older firmware.

So the only way to upgrade the logic board is to install a spare drive or use an external, then you have to go through the OS install process.

So you’ll need to do the same with a standard drive. Then lets see what happens then.

Was this answer helpful?

Score 2


APFS clearly causes more problems then it's worth.

It should be OPT IN; not forced.


Only an issue with SSD's! And you can program the installer not to upgrade How to: Upgrade to High Sierra without changing the file system to APFS

Take a read of these:

- The Speed of APFS Just How Fast Is It?

- Using APFS On HDD's... And Why You Might Not Want To

Now to be fair this are based on the first release of APFS and Apple has altered things in Mojave so we will need to see what falls out. Even still on PCIe/NVMe drives it makes a lot of sense! Just not on HDD's SSHD or SATA based SSD's


@danj as I stated, I am now trying this with an Apple branded straight 500GB hard drive no SSHD. I got the error when trying to install on a clean drive. Am now going through all the system upgrades, it just takes a while. But I think Apples intent was malevolent. I mean we are professionals and can't get it to work. The average Joe is SOL!


@mayer Agreed. Apple has just become so greedy since Tim Crook inherited CEO, all they want is you to buy new stinkin computers that are not repairable at all and they are just about hotter then the sun too. It’s unreal, and that’s why I stick to my old Macs (I still use a 2008 Core 2 Duo MacBook to this day!). iFixit saved my butt multiple times when my older Macs have broke down, so a big round of applause for iFixit.


@ajcooke01 iFixit helped you or was it the people who provide the answers, for no thanks?


Show 7 more comments

Add a comment
Most Helpful Answer

Dear all,

I had the same problem. Macbook Air 2013, internal SSD failed, and too expensive to be replaced. So I bought a 256GB Sandisk USB to install MacOS.

Initially, I Command-R to boot into recovery and tried to reinstall MacOS, but original was Mountain Lion. Installation was successful, but I wasn’t able to further upgrade to Mojave due to “.. missing firmware” issues.

Here is how I resolved:

  1. created Mojave bootable installation USB drive
  2. Boot into system with the above USB drive
  3. Before attempting installation, make sure to use Disk Utility to Erase/Partition the drive (USB thumb drive in my case) to APFS - IMPORTANT
  4. Exit Disk Utility, then click on MacOS install, which would proceed with the installation file from Step 1 bootable installation USB drive

worked for me, hope that helps!

Was this answer helpful?

Score 5


This worked for me! I had the same issue, 2013 macbook failed to boot to internal HD after coffee accident. I could not execute step 3 (drive utility could not unmount disk). So I added step 1.5 above which is to partition the USB disk (using a working macbook) to create a 2nd volume (I called it mymacos) on the USB drive using drive utility, to Mac OS extended and GUID scheme. Then boot to macos recovery (step 2). My step 3 is to use the disk utility to erase/partition the second volume (mymacos) to APFS, leaving the bootable volume containing the new 8 gb OS install file untouched (in my case I used Catalina). Then step 4 is exit utility, click on macos install, and install to mymacos volume.


Add a comment

Aha, OK. After some sleuthing it looks like you are kinda stuck now.

I just tried to replicate the same situation you have here, and I got the same results. I attempted install Mojave on a SSHD I had laying around, booted from it externally on my 2012 MBP perfectly, but when I tried an internal boot on the same machine it threw a giant hissy fit and gave me that error you stated.

That is one big fat L for the average Joe, and a giant nail in the coffin for Mac Laptops 2012 and earlier. Unfortunate!

You are not alone!

Was this answer helpful?

Score 2


You need to redo your test. This time install a standard HDD or SSD into the system and then install the OS so the system gets the EFI update.

I'm thinking the Seagate SSHD cache is getting in the way here. Once you have a working system then add in the SSHD.


@danj I re-did the test with a both a HDD and a SSD, I got the same issue on both those.


So you put in a standard HD into your MacBook Pro 2012 system. Then using a OS installer boot drive did a reformat of the drive and install of the OS?

I have a SSD in mine and it's working! Its still running the Beta release.


@danj It runs on an external but it does not run internal.


Show 4 more comments

Add a comment

Add your answer

mayer will be eternally grateful.
View Statistics:

Past 24 Hours: 39

Past 7 Days: 385

Past 30 Days: 1,555

All Time: 67,295