0

Score

Avatar
Joel Chan
1

Asked

Trackpad does not register my clicks?

History

My 4,1 MacBook's trackpad is not registrating my clicks. I can move the mouse but I cannot click. I have enbabled tap to click but it seems to be "disabled" when the trackpad button stops registrating clicks. This problem has persisted for a while and I was able to solve it by tapping on the trackpad button until it works again but today this solution is not working for me.

This might be a software and hardware problem but I have no idea what to do now.

- I have reset the PRAM

- I removed the battery to check if it is pushing the trackpad button In some way

- I held the power button for 10 secs with battery removed

I have do e everything I could think of short of going to the apple repair centre. I read somewhere they replace the top cover for White MacBooks for free because it is prone to defects/chipping etc

Edited by: machead3 and oldturkey03 ( )

Mac osx 10.6.6

Joel Chan,

Connected an external mouse, only right click works

Joel Chan,

I also ran fsck, fixed the volume, problem still persisting. Probably not software problem.

Joel Chan,

Add Comment Cancel

Post Answer

1

Score

Avatar
mayer
296.2k
MacHale Enterprises

Answered

Accepted Answer

PermalinkHistory

Boot up from your system installation disk, hold down "C" key on start up. See if the problem persists to determine if the problem is hardware or software. If software, reinstall the system.

Add Comment Cancel

0

Score

Avatar
bonz1121
1

Answered

PermalinkHistory

I'm having the exact same problem as you. even with the USB mouse and only the right button works. Its not a software issue. I already reinstalled the OS and still the same problem. from what i have read it looks like either ill need to replace the trackpad or the top case. I even went and adjusted the screw on the trackpad that controls the trackpad buttons sensitivity. still no luck. I also read about someone saying that the battery could be bulging and pressing on the trackpad buttons.. Thats not it either since i have taken the battery out and Im running it with it just plugged in. So hopefully helps you out on what not to waste your time on trying.

Add Comment Cancel

Add Your Answer

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 1,294