2.3GHz, 2.6GHz, or 2.7GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.7GHz) with 6MB shared L3 cache.

406 Questions View all

Replaced Battery, now only runs w/ power adaptor

I just replaced my battery using the repair guide here and did everything properly (as far as I’m aware.) When I went to turn it on, it would not turn on. After I plugged it into the charger it turned back on but showed “Battery not charging” and the power source is adaptor.

I reset the SMU and ran the Apple Hardware test but both indicated no issues. Everything runs fine otherwise and I have not noted anything else wrong. It is running off the charger… which makes me thing that isn’t the issue. I even dis/reconnected the battery part inside the computer just to be sure.

Any ideas on what I should do next or how this has been fixed before? I haven’t found any similar issues on this site after doing the battery replacement.

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

try to check your battery health by using any app

by

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Answers

Chosen Solution

@swagner3 Let’s do some testing of the battery. Download and run coconutBattery and attach a screenshot of the coconutBattery window.

Attaching Images to an Existing Question

Was this answer helpful?

Score 1

Comments:

Just updated it. Thanks!

by

@swagner3 Odd. It says its good, but the darn thing won't charge. Just to be sure, you should get another replacement just in case it is just a faulty replacement battery. iFixit supplies these types of batteries and they have a 1 year warranty on them where you can return them anytime for any reason. MacBook Pro 15" Retina (Mid 2012-Early 2013) Battery

by

Awesome, I will send them an email as well. Thanks!

by

@swagner3 Alright! Let us know how it goes!

by

Add a comment

Honestly, it sounds like a bad battery. If I’m not mistaken, the battery has its own board, with protection circuits and so on, maybe it’s damaged/faulty.

Was this answer helpful?

Score 0
Add a comment

I contacted support and they sent a new battery, which has been working great so far!

So my answer would be to contact support and request a new battery.

Thanks all,

Sam

Was this answer helpful?

Score 0
Add a comment

Add your answer

Sam Wagner will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 38