No start up chime and black screen. Any suggestions?

First I want to say this community is awesome. Now to the point. A friend gave me an A1138. He said it just stopped working one day. It's the only explanation he gave me. So this is what I have done:

-Reseated RAM

-Reset PMU (took battery out, which is dead anyway, and pressed power button for five seconds)

-Tried a different 65 watt power adapter (light still goes green even though battery is dead, but computer will not turn on)

Any other suggestions. I'm inclined to think it is the DC-in board. Am I off base in thinking that? Honestly the computer looks like it was taken care of, but nothing seems to be receiving power. I'm at a loss. Thanks for your time.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Is it the logic board maybe?

by

Do you get anything when trying to start? sounds, lights, smells

When you tried the other power adapter, did you try yours on the other machine to see if it worked? any difference between the two? Did you try it with the battery out?

by

Thanks for the reply lemerise and mayer. To answer your question mayer, I didn't get a peep out of it. No lights, no sounds, no smells. I did try a different 65 watt adapter that works fine on my friend's powerbook, but did nothing but glow green with the battery in and with the battery out. lemerise, I tried twisting around in the socket just to see if it was a loose connection and it remained a steady green the entire time. This is with the battery connected and disconnected. Since the adapter that came with the powerbook was an aftermarket adapter I could not tell a difference, beside the fact that powerbook had no reaction either way. Hopefully this weekend I will get a chance to open it up and take a look under the hood. Any other suggestions or things to look for are welcome. Thanks for all the help so far gentlemen.

by

Add a comment

2 Answers

Chosen Solution

If there's absolutely no electrical reaction when pushing down the power button it could be a DC in sound board issue (not cheap to replace, more than $50). Do you get a steady green light when the AC adapter is connected and when you rotate it in the DC in socket ?

If you're willing to open the machine using the iFixit manual for the 1138 (G4 15" 1.67 high res.) you may check the top case ribbon cables connections to the logic board. Just reseat the cables and try to power the machine with the top case still attached but not screwed. If no success, remove the top case by disconnecting the two ribbon cables, locate the the two power pads contacts on the logic board (check for the power icon or letters PW B written in white in the lower center of the logic board), gently trigger the two power pads with a very small metallic flat screwdriver with the AC adapter connected. If still no power then the DC in sound board or the logic board is probably faulty).

Was this answer helpful?

Score 3

Comments:

Thanks for the reply. I will check under the hood this weekend and let you know what I find. I also posted a comment above your answer that may have some relevant information. Any other things I should be on the look out for while I have the powerbook open would be great. Thank you for your time and help.

by

Sorry I haven't gotten back to you all. I have been slammed with finals. Once I'm finished I will give you a progress report. Thanks again for your help.

by

I opened it up and everything seemed connected. I bought an Apple original 65 watt adapter used for that model. The light still stays a steady green, but when I press the power button the caps lock light goes on and then off, the CD drive makes a noise that is normal for start up, and the fan turns on. But, that is it. No start up sound. Screen doesn't come on. Hard drive makes no sounds. The fan runs for a couple of minutes and then it shuts off. I'm at a loss now. Any suggestions?

by

A new development in my battle with this Powerbook. A friend gave me an A1106, which has the same model battery. I stuck the battery in the new Powerbook my friend gave me and it charged up and is holding as I type this up. So with the light from the power adapter (original 65 watt) steady green on the A1138, caps lock light going on and turning off, cd drive making normal start up noise, and the fan turning on and running like made for a couple of minutes...I'm starting to wonder where I should begin. Should I start with the DC-In port? Does any of this clue you all off to anything new? Thanks for your help.

by

Add a comment

With no sounds at all, it looks like it's getting no power past the DC-IN port, so I have to agree with lemerise. The first thing to do is find a cheap part to test with. Do a web search for Apple part # 922-6963.

Was this answer helpful?

Score 1
Add a comment

Add your answer

lsward will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 9

All Time: 3,706