Model A1288 / 8, 16, or 32 GB capacity

584 Questions View all

Why does this iPod touch still not charge with new battery?

I got in a ipod touch 2nd gen that wouldn't power on at all. I opened it up and found a very dead batter, popped in a new battery and bam it powered up. It still won't charge or even recognize that it is plugged in. I've tried several cables/computers/docks. All pins are in place in the dock connector and they are getting 5v in from the usb cable when plugged in, it just doesn't know it. Is there some known item on the logic board that is shorted causing this problem? Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

Jared just to make sure that when you soldered in the new battery, you verified that there is not solder that has flowed across the other solder pads, as well as making sure that the traces are all in working order. Did you check your dock connector on the logic board and make sure that all the pins are working and none are crossing over and causing you any issues. Also give it a try and charge it with a wall charger and see if that makes a difference. Anyhow, if you are certain that the battery is working nothing shortened out, you may try to replace the dock connector and take it from there. Good Luck

Was this answer helpful?

Score 1
Add a comment

Add your answer

Jared will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 859