1.83 GHz Core Duo or 1.83, 2, or 2.16 GHz Core 2 Duo A1208 (EMC 2104/2110/2114/2124)

257 Questions View all

Replaced original HD with 500GB but it isn't recognized. Ideas?

I did a major overhaul of an old 17" Core Duo 1.83, where I replaced the Display, the Superdrive and installed a bigger 500GB hard disk. The hardest part with the display was when reattaching the front case - I had the hardest time getting the top corners to "click" into place, especially the top left one. Finally got it in after about 15 minutes of trying and retrying. Any hints for next time?

I booted from an external Firewire hard disk with Snow Leopard restored to it, which makes installing SL on Macs with a Firewire port a bit easier than with DVDs. Never failed in dozens of installs. But for some reason my hard disk isn't recognized by Disk Utility or by System Profile. I was pretty careful installing it. There are only the 2 cables connecting HD and logic board, right? Possible defective hard drive?

Just wanted to ask if anyone has any ideas, before I have to open the iMac up again. Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

If Disk Utilities will not see it, there's not much you can do. Open it up and see if possibly there's a jumper on the drive. If so pull the jumper. Next I would remove the drive and place it in the external enclosure, start up from my system installation disk and use Disk Utilities to format it and install a system. If you can't see it in the external, return it. To test if you got everything back together correctly, insert the old hard drive.

Was this answer helpful?

Score 4


Yeah, unfortunately it sounds like a bad disk. When I booted up from DVD this morning I could hear a click click click inside the iMac. Bummer. I just ordered a universal drive adapter so that I can test disks and burners before installing them in our Macs, so as to save time and hassles. Thanks for replying.


I use the NewerTech universal adapter.


Add a comment

I have an Imac core duo too, and because I guessed my OSX 4.11 was corrupted, because was slow; some -5 minutes- at the start up and had problems reading DVDs, all these symptoms started when I tried to back and forward some scenes from a rip DVD movie using the VLC player. 3 times this movie freezes the mac, but at the third try of rebooting to continue the watch, the Imac started to reboot to a blue screen.

My choice was to create a new user, and this helped to reboot again, but with the problem of the slow start up.

lately I bought a new Hard drive to replace this one, that I thought was corrupted.

But the new Hard drive, a Seagate Barracuda 500gb (3g/s) was not recognizable by the OSX disks at the moment of install the OSX into the hard drive. The HDD icon in the set-up displayed a caution sign over the hard disk icon, which normally have a green approval slash to determine the disk is OK for installation. The operation was'nt possible.

Then, after some time using the Old HDD with the slow start up issue...the HDD show new bad start up, so I decide to erase and put the OSX back into the same old HDD using the original Installation disks.

The fist try was good, all 2 disk were installed, but when the imac asked for online updates as the update was happening the computer started to slow the normal interface movements, as moving icons and folders.

And when I tried to start up again the Imac started up in blue screen only.

Then trying to install the disk was not possible, the disks or the HDD fails to write or read the installation, I was clueless. And After a few tries the Installation disk where ejected out of the drive.

The only way to reinstall and read the OSX disk was to enter disk in Hardware test, then restart from its interface and turn on key "C" to install the OSX. Disk1

Installing the disk1 was possible, asking when installed for the disk 2, as normal. But the Disk 2 installation had problems from soome point. Always stucked in the Iwork'06 software installation step in the progress bar.

I have tested this original HDD as an external drive in another mac, and all seems to be Ok with the hard drive.

But when I try to connect the Imac (with the original HDD inside) to an Ibook through a Firewire cable in "T" option, That HDD appears only in the Disk utility interface, but not in the desktop in the Ibook. I can't make installation this way because Ibook G4 PPC and Imac Core duo are not compatible processors.

I bought a new HDD WD like the original internal HDD, but the same problem as with the Seagate.

All these 3 HDD are Sata II or III randomly, ironically I saw reviews in which my original WD HDD it's a SATA III, but it's just because of the transfer (3GB/s) perhaps the Imac is from early 2006 production date.

I have no idea what is causing the problems here, any hint, idea or solution?

Was this answer helpful?

Score 0


Start a new qustion.


Add a comment

Add your answer

Matt will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 800