Skip to main content

Fix Your Stuff

Right to Repair


Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

912 Questions View all

One beep with black screen, unable to start


Been reading all answers, but my situation is a bit different. We have decided to upgrade an old MB Pro mid 2010 with 2 x 4GB RAM and SSD. Looking through the MB before upgrade, the battery suddenly started to bulge up and actually twist the entire frame and push the trackpad up. I immediately removed the battery, and tried the MB with just powercable connected. All worked fine. However, next morning before starting the upgrade I turned on the MB - or tried. Black screen, and single beep.

I have then tried all possibilities, PRAM and SMC reset, cleaning of RAM slots, new 4GB RAM in both slots, all to no avail. Even tried to undo and retighten (lightly) the 4 screws holding the RAM socket.

Any suggestions? I am afraid that the swelling of battery and subsequent twisting og entire frame could have damaged the logic board? But if so, how come it worked for several hours after battery removal?

Answer this question I have this problem too

Is this a good question?

Score 0


Is the single beep repeating after a few seconds if you keep it on ? or just a single beep and that's all ?


It continues with same interval (approx 3 secs) until I turn it off. And the white LED on front blinks with it.


That sounds like a Ram issue, have you already tried reinstalling the old sticks ? Sometimes for apparently no reason, perfectly working Ram on one machine won't work on another and viceversa.

Your new sticks are pc3-8500 ?


Yes, tried all options with RAM. There was one 4gb already installed, moved it to the other slot. Installed new RAM in first one slot, then the other. And tried to mix the old and new 4gb slot in both slots. Absolutely to no help. And the RAM is confirmed to be correct, Crucial 4GB DDR3 - 1066 SODIMM (Specs: DDR3 PC3-8500 • CL=7 • Unbuffered • NON-ECC • DDR3-1066 • 1.5V • 512Meg x 64 • lead free • halogen free • for Mac)


A Ram problem after resets and different attempts at ram sticks exchanges leaves us with a logic board issue. I'm not able to think about other alternative explanations, would need deeper testing on a workbench.


Show 2 more comments

Add a comment


RAM Upgrade Kits for Mac

Shop Kits

Enough RAM
For All The Tabs

Shop Kits

1 Answer

#1 unscrew the device and unplug the battery

#2 wait a few seconds plug back in the battery and start up the MacBook

Was this answer helpful?

Score 0


Unfortunately the beeps started before the battery was installed. And I have tried with new fully charged battery to unplug this and reinsert. Still beeps.....


try resetting the ram


Add a comment

Add your answer

soren will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 16

All Time: 600