Replaced left fan for MBP A1151, and now have no sound.

I recently replaced the left fan on my MBP A1151 using the replacement guide. All went well, but when I booted back up, there was no sound output. The initial little chime that sounds when the computer first turns on is there, but I have no audio output from within the OS. I opened it back up and rechecked all connections, and everything looked good. I was having no audio issues before the repair.

The fan is working fine.

Please help.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Reseat the speaker connectors: MacBook Pro 17" Models A1151 A1212 A1229 and A1261 Left Speaker Replacement

Look in the audio port and see if you see a red light on.

Was this answer helpful?

Score 3

Comments:

Thanks for the response. I did a little research and resolved the issue. Yes, I did have the red light emitting from the port. It's my understanding that this model has optical audio, and somehow this feature was turned on during the install. Is that your understanding as well? I simply plugged in a set of headphones, and the audio returned.

Thanks again. The fan is working great! No more painful noise from within.

by

That's exactly why I asked about the light. Glad alls well. Keep an ear out for that other fan.

by

Add a comment

Hi, i replace my left fan and after this, sometimes i have sound and others no.

I have a Macbook pro 15 A1211.

What i can do?

Anyone can help me?

Thanks

Was this answer helpful?

Score 0

Comments:

Check your speaker connections. If this fails start a new question.

by

Hi, whats plugs i need check?

Thanks.

by

See the link I gave above for installing the speaker

by

I just see, but the model of macbook pro is diferent.

Thanks

by

Add a comment

Add your answer

rbunkers will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 537