0

Score

Avatar
Gareth
1

Asked

LEDs power on then off!

History

Diagnostic LEDs flash then go off

History • Edit • Delete • Add Comment

I have the 20" alu iMac which refuses to start. A1224

From cold the iMac led diagnostics show led 1 as on, but as soon as I press the power button LEDs 2, 3 and 4 quickly light accompanied by the optical drive fan. Then nothing.

Even led 1 goes dead..

I have to leave the machine off foe a few minutes before the led 1 will power on again!

I have already swapped the power supply but have the same issue.

Could this be the power cable 922 8188 as documented on some YouTube sites?

Thanks for your help in advance.

UPDATE 4/29/11

I have now replaced both the power supply and the power cable that feeds the logic board and hard drive... Still nothing...

The only thing worth adding is that once the machine has cycled on and then off ... If I leave it for 10 minutes or so it allows me to attempt power on once again... But each time all I see are the LEDs flash on in sequence with activity to the fans ... Occasionally the DVD drive starts up all this with or without the screen connected...

Any more takers for advice, as I have replaced everything with the power except the actual ac filter itself. Could it be that?

Gareth

Edited by: mayer ( ) , Gareth ( ) , mayer, rj713, and machead3 ( )

Add Comment Cancel

Post Answer

2

Score

Avatar
mayer
291.1k
MacHale Enterprises

Answered

PermalinkHistory

Here's what the Apple book says:

LED Startup Sequence

LED #1 = Power available.

If no LED is visible:

• Verify AC source

• Verify known-good AC cable is connected

• Verify cable connection between AC inlet and power supply

• Verify cable connection between power supply and logic board

• Verify power supply

LED #1 + LED #2 = Power available, and system is powered on.

If second LED is not visible when power button is pressed:

• Verify power button connection to logic board

• Verify power button functionality

• Verify cable connection between power supply and logic board

• Verify power supply

• Verify logic board

LED #1 + LED #2 + LED #3 = Power available, system is powered on, and video card found.

If third LED is not visible after power on:

• Verify that MXM video card is seated properly

• Verify logic board

LED #1 + LED #2 + LED #3 + LED #4 = Power available, system is powered on, video card found, and internal LCD found.

If fourth LED is not visible after power on:

• Verify cable connections between LCD panel and logic board

• Inspect LCD display cables for cable damage

• Verify external video functionality, and according to result check the following items:

-If external display works then verify/replace LED backlight board

-If external display works then verify/replace LCD panel

-If external display does not work verify/replace logic board

Edited by: Gareth ( )

Thanks for that... I had seen that on previous posts, but my issues that all the LEDs go off after cycling on. I read this as a faulty psi, except after swapping it out I still have the same issue.

Gareth,

What was your source for the new power supply?

mayer,

It was bought from Applerepair on eBay in the UK as a new unit.

Gareth,

Add Comment Cancel

0

Score

Avatar
Danno
247

Answered

PermalinkHistory

Had 24" iMac that exhibited the same symptoms. Diagnosed with bad logic board by respectable shop.

Add Comment Cancel

Add Your Answer

View Statistics:

Today: 0

This Week: 0

This Month: 0

All Time: 1,115