Skip to main content

Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

528 Questions View all

Laptop Will Not Power On and Magsafe shows No Light

Laptop was working perfectly fine, had about 60% battery left the other night when I shut it to go to bed. When I closed the computer, I accidentally closed it a little harder than normal, but no noticeable physical damage done and I went to sleep. Next day, went to use it and plug in my headphones, opened it up and it wouldn't power on. Plugged in the MagSafe adapter and it showed no light what so over.

I am pretty sure the charger is not broken, for the battery had charge in it the night before and I tried my brothers macbook air charger (which I have used in the pass) but it too shows no light.

Tried doing the whole SMC reset, no luck. I took off the back and disconnected the battery, held down the power button for 15 seconds, let it sit for awhile, then reconnected everything and still same issue.

Interesting note: when I had the back off, I tried the SMC reset again and still no luck, however I noticed the fan will kick on for half a second at a super low speed then turn off. Barely noticable, but I noticed it happens as soon as I let go of the four buttons after the 10 seconds.

Any help would be greatly appreciated. My best guest is from closing it hard something got knocked out of place maybe. My 2013 Macbook has a newer 2015 retina display screen I swapped onto it when I broke the screen. Dont think this would have anything to do with the problem since it was working fine with the new screen for several months, but thought I'd mention it. Thank you!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

well it sounds like one of the power supply cables heading from the battery got knocked out of place so i would check there

Was this answer helpful?

Score 0


Where would these be at on the Macbook? Could you post a diagram of what exactly I should be looking for?


So I found a post somewhere that said to do the SMC reset by holding the three keys while simultaneously plugging in the power cord instead of pushing the power button. I tried that and the Mag Safe cord actually lit up and showed the amber light and the screen came on saying the battery needed to charge. After about an hour however, the light is still amber and will not turn on or show the dead battery screen. Tried and SMC reset again but no luck.


i don't have a mac so i can't get pictures, i would say look towards the battery and the charging port


Add a comment

Add your answer

cyrusmirhaidari will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 16

All Time: 467