Released in 2013, Model number 19150 (Green) or 19167 (Pink)

7 Questions View all

Why won't my computer see this device?

I have plugged in My Own Leaptop to my computer and would like to reset the name. But it will not show as connected. The USB is fine, I just changed the name on a Violet Leapfrog doll with the same USB.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

Hi,

Has it worked before OK, when connecting it to a computer via USB?

Have you got the Leapfrog connect program installed in your computer?

This will install the drivers so that your My Own Leaptop will connect via USB

Update (05/26/2018)

Hi,

Use a strong light and a magnifying glass to check the USB port to ensure that all the pins are there and that they are straight and parallel with each other.

Also check for any lint etc., which may be in the port enclosure. If there is use a vacuum cleaner to suck it out or if necessary use a wooden toothpick to gently dislodge anything trapped in there.

If the port seems OK perhaps it has become dislodged from the systemboard.

Here's a link to the ifixit Leapfrog My Own Leaptop Keyboard Buttons Replacement Guide which may help in gaining access to the systemboard so that it can be inspected.

Was this answer helpful?

Score 2

Comments:

yes, it worked before when we set it up for the first kid. I reinstalled the LEapfrog app and just completed a re-set of another Leapfrog item (Violet) successfully. Same usb cord. It's almost like they no longer support the My Own Leaptop. It's 7 years old.

by

Add a comment

Hi Evan Ryan, I suppose you are mentioning about the USB cable is fine.

I would like to know more about the history of this devices,

If device has been dropped from a height?

Liquid was contacted with the devices?

Check on the device if the mini USB port if it has been damaged or loose.

you might need to open up to check if it is soldered in place .

Was this answer helpful?

Score 1
Add a comment

The item and software have been discontinued in 2018. I've been trying to do the same but finally found the answer on leapfrog website. That's a shame. It's a good toy and it's going to waste because I can't reset the personalization.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Evan Ryan will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 52

Past 30 Days: 227

All Time: 429