Upgrade to SD card not working

I tried to upgrade my Ipod classic 160gb with a 128 gb sd card. It keeps going into recovery mode. If I reset it, then put music on it slowly, I album at a time, then eject it. I can usually get up to 10 gb on it. Then It goes into recovery. It will recognize the card, and the amount of data on the card, but in the menu it says 'no music'. Have tried it in a 5th gen 30 and a mini with the same result. I have had far more success with compact flash cards. The sd cards give me trouble, Am I doing something wrong. I tried different adapters with the same result.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Have you tried another SD card?

by

I have tried different sd cards and micro sd cards. Been trying all day with a 7th gen classic 160. Always works for a while, then it just says no music. Puzzling part is that it will recognize the data(10 Gb used) but not what the data is.

by

Which format have the card? Fat or another?

by

I have tried xFAT and NTSf. Both give the same result. Tried different cards, different adapters and different ipods. All the same result. Gets close to 10 gb and no music

by

Add a comment