Will this iBook run OS 10.5.8?

Just had this iBook fixed was running OS 10.5.8 for a month (no startup disks) ran a repair program macware tools pro and it would not start past a picture of my HD. repair people had to gedt CD ver. 10.4.5 to start it w/clean install.All mine were DVD. Said that was the recommended Ver. max for book? True? I'd like the higher OS.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

You don't have the processor speed required for 10.5

Mac OS X v10.5 Leopard requires:

A Mac computer with an Intel, PowerPC G5, or Power PC G4 (867 MHz or faster) processor

512 MB memory or more

A DVD drive for installation

9 GB of available disk space or more

A 10.5 system can be installed on the hard drive if placed in a G4 867 + MHz processor machine or a G5 and then returned to your machine.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Michael will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 853