Skip to main content

Compaq Presario CQ62 laptop

42 Questions View all

Why my pc powers up for a few seconds and then goes off before display

it does not reach the boot process and also does not display anything. If you press the power button it just turns on for not more than 10seconds and it goes off.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Hi @sirmek ,

What is the model number of the laptop?

Does it do this with the charger connected and switched on?

Can you hear the fan start up?

by

my pc is an hp COMPAQ

by

Hi @sirmek ,

Yes but what is the model number? Look at the back of the laptop or on the underneath to find it on the label.

Also what about the other questions I asked?

by

the model is CQ62-a10SA

it does this both connected to the charger and switched on

the fan does not even start up

by

Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

2 Answers

Chosen Solution

Hi @sirmek ,

Try the following:

Switch off and disconnect the charger if it is connected.

Remove the battery from the laptop.

Press and hold the laptop Power button for 30 seconds to drain any residual power from the laptop.

Reconnect the charger to the laptop and switch it on. (leave the battery out at this stage).

Turn on the laptop and check what happens.

If it still doesn't turn on, there is a problem with the motherboard. (Has the laptop been dropped or gotten wet at all?)

If it does turn on, allow it to boot all the way to the Windows desktop. Allow the HDD activity to settle then shutdown the laptop in the normal manner.

When it has completely shutdown, switch off and disconnect the charger.

re insert the battery and reconnect the charger and switch it on.

Turn on the laptop, allow it to boot all the way to the Windows desktop. Allow the HDD activity to settle then check the charge status of the battery.

if it is charging allow it to fully charge before switching off and disconnecting the charger.

Was this answer helpful?

Score 1

Comments:

I have tried it severally but no change

the computer does not even reach the boot process

by

Add a comment

try changing the cmos battery or just simply taking it out for 5 seconds and put it back again

Was this answer helpful?

Score 0
Add a comment

Add your answer

Munyar will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 76