Model No. A1367 / 8, 16, 32, or 64 GB capacity

1269 Questions View all

Facetime all of sudden not working, what to do?

Facetime all of a sudden would not except password, changed it and still would not work. What to do?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Have you tried signing into FaceTime on a Mac? Will it accept your password there?

If that still doesn't work, your best option would be to restore your ipt4g to factory defaults and try it from there. It's likely that something corrupted itself in your software. Replacing that software with Apple's stock software will typically help.

Let me know if either of those solutions work.

Was this answer helpful?

Score 0
Add a comment

Under settings, try signing out of the app store, then signing back in. Did you recently change your email?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Alice Wriston will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,393