4-inch iPhone released in March 2016 with similar hardware specifications to the 6s. Available in Silver, Space Grey, Gold, or Rose Gold with 16/64 GB storage options. Model A1662 and A1723.

466 Questions View all

Display froze and faded out, but still doesn't work after replacing.

I was using my SE when suddenly the display froze, developed a really strong red and purple tint, and got lines all over it. Then after about fifteen seconds it faded to black. I force shut it down but it didn't seem to turn back on. Later on I plugged it into my computer and iTunes would recognize it(but wouldn't connect because I couldn't unlock it). I talked to Apple Support for a long time and after trying to update it in recovery mode, they said that it's likely that the display broke. But my display's in very good condition, and I just swapped it out with one from another iPhone SE, and I'm still not getting any picture or backlight from it, and the display from my phone works perfectly fine on that other SE. I'm pretty sure that the phone right now is stuck in the setup menu after updating it to iOS 11.3 (which it was already in), so I can't use the mute switch or Siri or QuickTime streaming to find out if anything else is working (iTunes was being difficult about recognizing it for a while, but now it is). This is seeming to not be a display problem, right? Really hoping this is something I can fix without needing to take it into Apple or buy a new logic board or something. Thank you.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Or is it also possible that this is a problem with iOS 11.3. It seems like that updating is causing a lot of display problems for people?

by

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Most Helpful Answer

If it were just a black screen, I would say that it may be stuck in DFU mode. However the purple fade and lines seems more like a hardware issue than anything else.

I would download 3uTools and connect it again to see what 3uTools determines about the state of your device. If it is in recovery mode, you will be given the option of taking it out of that mode. If it isn't, you could try to enter DFU mode and do a fresh install of iOS 11.3. Unfortunately, iOS 11.2.6 is no longer signed so you can't downgrade.

If none of that works, then you likely have a hardware issue on the logic board, which will require a micro-soldering repair.

Was this answer helpful?

Score 3

Comments:

3uTools isn't recognizing it, but that may be because I'm running it from Wine on my Mac. Is there anything else I can try, or do I need to use it on a PC, or virtual machine?

by

I've never tried running 3uTools on virtualization software, so I couldn't say.

by

Thanks for your help. I haven't gotten to try 3uTools on a PC yet, and I can't get my virtual machine to connect to the internet, but do you think it's worth trying to restore the phone to my last backup, when it was working, or is it probably not going to fix anything? Putting it back to the last backup would mean it wouldn't be in the setup menu anymore, so I might be able to better test the vibrator and sounds, to find out if it's booted properly.

by

IF the problem is iOS related, then going to a previous restore state won't change anything, it won't put back the old iOS.

by

Add a comment

Add your answer

Ezra will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 73