Skip to main content

The March 2015 update of Apple's 13" MacBook Pro Retina Display, model A1502, features fifth-generation Intel Core i5 and i7 processors and introduces the Force Touch trackpad.

1197 Questions View all

MacBook Pro 13 early 2015 not charging even after replacing battery

My Macbook Pro stopped charging and I could only turn it on while plugged in, so I opened it and discovered the battery had swollen. But even after replacing it it's still not charging, and even though the battery indicator now says it's at 56%, as soon as I unplug it the laptop dies. The MagSafe light is Amber color so I guess it is receiving power but the laptop won't charge. I also tried SMC and PRAM resets several times to no avail.

Anyone knows what could be the issue here?



I checked the MagSafe adapter but didn't find any issues according to the Apple Guide Apple Portables: Troubleshooting MagSafe adapters

Calibrating the new battery following this guide How To Calibrate a Mac Laptop's Power System. It suggests if the laptop doesn't start up without the power adapter connected I should verify that again, but I'm 100% sure it's correctly installed.

I followed this guide: MacBook Pro 13" Retina Display Early 2015 Battery Replacement

Finally, this is what I get from CoconutBattery:

Block Image

Answer this question I have this problem too

Is this a good question?

Score 4

Did you have the MageSafe plugged in when you did the screen capture? It appears the system is not charging!

This is looking like your charging logic is damaged on the logic board.


Yes, it's plugged in but not charging and as soon as I disconnect it the laptop dies. That's what I described in the question.


Did you ever resolve this? I have exactly the same issue with exactly the same MBP model, with two slight differences:

1. I replaced the battery after the computer was dropped and got a dent in the bottom, which after disassembling was clear was deep enough to gouge one of the battery cells. (Before replacing the battery, it exhibited all the same symptoms as with the new battery, except that with the old battery it reported the charge level as "0%," and with the new one "88%.")

2. The coconutBattery "macOS Battery Status" line says "poor." (I think this is because the new battery is reading as having 2/3 of its original capacity, which I suspect is because it hasn't been calibrated, but maybe also means the battery itself is bad. But either way, it sees the battery, sees it has voltage, doesn't report anything is catastrophically wrong with it, but won't run off it or charge.


Add a comment

3 Answers

Most Helpful Answer

First you may need a new MagSafe power adapter. Check this Apple T/N to make sure you have the correct one and the things you need to check: Apple Portables: Troubleshooting MagSafe adapters Make sure the cable & connectors are in good shape. Any damage you should replace the adapter.

Next did you calibrate your battery? Here's a good write up: How To Calibrate a Mac Laptop's Power System

Lastly, you should download this gem of an app! CoconutBattery If you are still having issues lets get a screenshot of the main window and post it here for us to see. Adding images to an existing question

Update (04/07/2018)

At this point your logic board will need repairs there are a few possibilities on what will need to be replaced there is a MOSFET that might be bad or the voltage comparator logic is damaged.

Was this answer helpful?

Score 1


That's what I feared. But why did that happen? I mean, did the battery getting swollen damaged the other parts? Or what was it that started the problem?


There no real way to know what was the root issue here. The charger could have been defective or the MagSafe connection shorted somehow. The logic board damage could have caused the battery to over charge or the battery shorted out causing it to swell and damage the logic.

You get to pick ;-}

Bottomline your logic board needs repairs at this point.


Thank you for your help.

Are there any risks (for the laptop or myself, lol) if I keep using it plugged in at all times but with the new battery?


I would recommend you disconnect the battery for now and just use the MagSafe. You don't want to mess up your new battery! Better yet get your system serviced ASAP.


Add a comment

With mine, I installed the battery and charged to 100%, I thought. I only used the MagSafe light turning from amber to green to indicate that it was at 100%. This only took a couple of hours. I allowed it to stay on the charger for two more hours. Then, I booted it up and started using it. It took about 4 hours to fully discharge. I let it sit overnight before reconnecting the MagSafe. I thought it was charging but apparently not. It says it has 0 cycles, 0 mA*hrs and no information on the battery.

I thought I had my battery status in the menu bar, but when I check that box, it immediately unchecks itself.

Was this answer helpful?

Score 1

1 Comment:

Used a IFixit Battery Replacement Kit.

There is a YouTube video that says this can be caused by two restores on the logic board. Unsoldering those and replacing them fixed the video example. I have not risked trying my soldering skill on this yet.


Add a comment

Did you or anyone ever get an issue like this sorted out?

I have a seemingly good battery (according to coconutBattery) of the same Simplo brand that won’t charge.

What I find so odd is that changing back to the swollen original Apple battery the machine will charge and run just fine of the battery, only problem is that it’s so big and swollen now that it’s nearly twice it’s intended thickness.

This makes me suspect a faulty battery even if coconutBattery indicates it being good, perhaps an issue with the battery brand???

Was this answer helpful?

Score 0

1 Comment:

Did you follow the answer I provided? Can you post a snapshot of CoconutBattery here for us to see.

The fact your battery is reporting within CoconutBattery is a good sign!

The fact the battery is a Simplo brand is not very informative! The problem is some 3rd party battery makers basically copied the micro-controller firmware from a good battery (i.e. Simplo) so you can't depend on the name as being the real Simplo battery!

You can thank Apple for not offering batteries and parts to 3rd parties! Support the Right to Repair!

Just look at how you can go to a local car dealer and buy the original parts from them! Can you do that at an Apple Store or authorized Service Center?


Add a comment

Add your answer

Andrés David Liu Fong will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 32

All Time: 6,892