No video at all

Hi everyone, I hope someone could assist me to repair my MBA first gen, so the problem is , after I press on/off button, it looks or seems to be starting, chime sound on, the fan is turning, caps-lock key turn on when I pressed, but still not showing any video or displaying something just got blackscreen, and I try to add some baclklight effect from other small torch, it shown nothing either....

what should I do....kindly need your hellp or assist to solve my problem,

thank you

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

To isolate the problem hook it up to an external monitor and let us know the results. Have you had any problems with your hinges or spilled anything on it. You can try to access the hard drive by using Target Mode and hooking it up to another Mac via a Firewire cable and booting holding down the "T" key.

Was this answer helpful?

Score 1

Comments:

I havent try to connect it to external monitor yet, I'll try it later at home, but I'm sure nothing spilled into or on it, I did try removing the hard drive and start it, but once again it just the same, no white screen, no circle turning, no apple logo, no light, nothing, just chime without change or error message that I can see... is there any other step wich I can try, please your assist....

by Daniel Fajarsyach

I did try to connect to an external display, but still not showing anythings, and I also try a SMC reset from your refer page, done that but still no magic, this very frustating, and now even worst, after several try of restarting, open/close lid now it just get sudden turn off 3 second after I press on/off button, no chime.... please help me....

by Daniel Fajarsyach

Add a comment

Add your answer

Daniel Fajarsyach will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 25

All Time: 2,579