Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

991 Questions View all

Formatted & installed OS has disappeared from new replacement drive!

I am trying to upgrade the hard drive in a a mid-2012 MacBook pro to a 1 TB Toshiba replacement drive. I formatted the new drive, downloaded a clean version of OSX from Recovery (I think Mavericks, at least that was the background image), and set up the system. All of this I did with the new Toshiba drive attached as an external drive to another Macbook Pro. I was able to give the new drive a name, and all seemed well.

The new drive mounted fine as when mounted from the other laptop, I could see all the standard OS installed files on it.

When I installed the drive into its new home in the old Macbook, it's not recognized in any way (continuous flashing question mark). I went through the process of mounting it as an external drive attached to the other Macbook, and tried to set the new OS as the startup (and thought it worked), but it still wasn't recognized when put back into the laptop. It's not the cable; the old 250 GB I want to replace still boots fine.

Then I tried to do a complete new Recovery format and install (while the drive was in the laptop), but Recovery couldn't find the drive either.

Now when I try to go and retrace the original steps (formatting the new Toshiba drive from another MacBook with Disk Utility) the new drive won't mount anymore. It's totally invisible/uncommunicative.

I think I understand that there's a difference between an external bootable drive and an internal bootable drive, but right now I can't get to the drive at all, to do anything with it or make changes.

What happened, and how can I fix it??

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

@mayer - I think it was a GUID format -- the default, as I recall, when I formatted with Disk Utility. Would that be right?

Could a drive fail after seeming to work properly? It wasn't a failure (in this way) right out of the package, for sure.

@danj - the cable doesn't seem to be a problem. I reinstalled the old 250 GB drive and it's working fine.

by

99% of the cases: replace the SATA cable. These are notorious for failure.

by

As a matter of course I always replace the cable when I replace the HDD or upgrade to a SSD. Here's the IFIXIT guide: MacBook Pro 13" Unibody Mid 2012 Hard Drive Cable Replacement and here's the needed part: MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable. In addition I place electricians tape down on the uppercase where the cable rests as the rough aluminum surface of the uppercase wears the cable. Also don't over bend the folds.

by

Add a comment

2 Answers

Most Helpful Answer

Sounds like the new drive failed. Also did you format the drive GUID, MacOSX journaled? You can install a system on an external drive with any format and boot from it externally, but when you move it internally it has to be GUID.

Was this answer helpful?

Score 3

Comments:

@mayer - Don't forget the cable!

by

See if the cable has any marks on it as it comes over the top step and onto the optical drive.

by

Add a comment

I've seen this a couple of times. I resolved it by resetting SMC and zapping the PRAM.

The other thing to check is some OS X installs need to update the laptop's internal firmware.

If it is the latest one (High Sierra), you will have to find an old OS X to install on the hard drive, then upgrade manually on the laptop you intent to upgrade the hard drive on, as the firmware is mandatory.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Paideia School Library will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 47