Skip to main content

Repair guides for Android cell phones manufactured by ZTE.

1267 Questions View all

It won't download anything

I've done something with the data. The phone does not download any apps.

Answered! View the answer I have this problem too

Is this a good question?

Score 22

But my brother has the same phone and it let him get the app


Can you help me get it


Can you help me get it cuz I've been trying to get it for the past few days and I really want it so please


Can anybody help me update my phone


Hi there my showbox froze so I have turn off my phone and put it back on again and still the same so I deleted it and now I can't install it again it say app not installed


Show 8 more comments

Add a comment

3 Answers

Chosen Solution


Can you access the internet OK?

If not, go to Settings > Wireless and Networks > more > Mobile Networks > Data Connection and make sure that it is enabled.

If you can, have you tried updating the Google Play Store app?

Open the app, tap Settings, scroll down to Build Version, tap to enter. If there is an update option select it and allow it to update. Try to download an app and see if it works.

If it says it is already up to date, try the following:

From Main Menu on phone go to Settings > Apps > swipe left to All > scroll down to Google Play Store, tap to enter, tap clear data. Try to download an app.

Hopefully this may be of some help.

Was this answer helpful?

Score 12


Has anybody else tried it?? I'm tryna get fpse back n now I can't download nothing from tha playstore


OK so I figured it out jus uninstall latest updates for Google play


the uninstalling of updates for the play store worked for me thx


How do i uninstall latest updates ?


Hi @ Jeremy Brown,

if you have a ZTE phone go to Home screen > Apps > Settings > scroll down to Apps > in "Downloaded" apps column (swipe right to left if you can't see it listed on screen, scroll down to Google Play Store > tap to enter > tap on Uninstall Updates and follow the prompts.


Show 10 more comments

Add a comment

Hi @Particle_Falls

Try starting the phone in safe mode and check if the internet speed is OK.

If it is then a downloaded app is the cause of the problem.

The trick is to find out which one is the culprit.

You need to uninstall each download app, one by one and then test the phone in normal mode between each uninstall.

When it operates OK the last downloaded app that was uninstalled was the culprit.

Also check to see if the Play Store app needs to be updated.

When in safe mode, open the Play Store app and select Settings. Scroll down to About and tap to enter. If there is an update option tap it and follow the prompts.

Was this answer helpful?

Score 1

1 Comment:

Wow it actually worked thanks so much!


Add a comment

Ok y'all, here ya go simple and plan thank GOD!

Step are -

  1. Go to Settings
  2. Go down to Reset Options
  3. Go to Reset Application…
  4. Select Reset App Preferences
  5. You will receive a prompt telling you the result of your choice
  6. Select Reset Apps
  7. Jackpot!

Was this answer helpful?

Score 0
Add a comment

Add your answer

michael Shiflett will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 18

Past 30 Days: 100

All Time: 36,596