Skip to main content

The Sennheiser RS 120 is an RF wireless headphone system with open, supra-aural headphones.

52 Questions View all

Worked for years then stopped. New batteries fully charged. Reset. No

Worked for years,then stopped. New batteries charged overnight. No good. Unplugged power, sound, removed batteries 30 min. to reset. Green light is on. Still no good. Now what?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Have you tried re-tuning the headset to listen if you can pick up the audio. The tuning wheel may have been shifted

If this doesn't work try changing the transmit channel (switch on bottom of base unit) and then re-tuning the headphones to see if it now works OK.

Block Image

(click on image to enlarge for better viewing)

Was this answer helpful?

Score 3

4 Comments:

Good suggestion. Not successful. Slight hearing left side, BAD bass static right side.

by

Hi,

I know that you said that the green light is on, on the base unit but can you verify that there is actually audio available at the end of the cord coming from the audio source and not just a "loud" static or hum?

If you have another pair of 'standard' earphones plug them into the output of the audio source (if the plug is suitable that is). to prove that the audio is good leaving the source. Then if you have a speaker with the appropriate input connection plug the cord from the source into that to prove that the cord is OK.

Just trying to narrow down where the problem may be.

by

Good advise, I'll see if I can find an old pair of headphones to try. And/or a speaker. But again, there is some audio on the left side but it sure doesn't have much volume. Thanks

by

Unit lights are off plus headset doesn’t connect to the base

by

Add a comment

Add your answer

Hal Norling will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 16

All Time: 1,127