2.5 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.1 GHz) with 3 MB shared L3 cache.

168 Questions View all

installed new battery, doesn't display

installed a new battery, but it doesn't display.

Shows white battery icon with white X inside on startup, but after login there is no battery icon.

Doesn't even show the battery in coconut battery.

Did a SMC reset and P-RAM reset, neither worked.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Where did you get the battery?

by

Add a comment

1 Answer

Chosen Solution

I've seen this before, double check the battery connection as sometimes it can be finicky and just need an extra little push or a re-seating, even when it looks and feels good. If that doesn't work I'd worry about where the battery came from and/or if its a defective part. If a different battery still doesn't fix the issue there may be a larger problem with the computer. Hopefully this help, Good Luck!

Was this answer helpful?

Score 1

Comments:

This!

Actually just unscrewed the screws for the battery and screwed them on really tight and it worked.

When I did it the first time I screwed in the speaker screws with barely any pressure and it caused a hairline crack on them (doesn't affect function though), so I guess I was a bit cautious afterwards and didn't screw in the battery screws tight enough the first time around.

Thanks!

by

Add a comment

Add your answer

jason will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 29