Skip to main content

Repair guides and support for LED, LCD, HD and other Vizio TVs.

543 Questions View all

E420i-A0 picture and sound keep going out

E420i-A0 When first turned on everything works fine for a few minutes. Then the screen will go black and the sound stops also. It will then come back on sometimes for a couple of minutes, and then go out again completely. I can then press the power button and the V will appear followed by HDMI-1, DIRECTV, in the upper right corner. Also "1080i" flashes on and off to the right of DIRECTV. No picture or sound appears. If I turn it off and leave it for a couple of hours, I can go through the same routine all over again. My thought is that one or more components on the boards is getting hot and breaking down. Any suggestions? Thanks

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

2 Answers

Most Helpful Answer

@provmobile this sounds like an issue with either the power board or the main board. It could be capacitor failure which would manifest itself with the symptoms you describe. remove the back off your TV and take some good pictures of all of your boards. Post those with your question so we can see what you see. Use this guide Adding images to an existing question for that

Was this answer helpful?

Score 1

Comments:

Thanks, I will have to have someone take it down for me as I am disabled so pictures can be taken.

by

Add a comment

Sounds silly but have you tried new cables, especially if you have a cat. Cats seem attracted to VGA and HDMI cables.

Was this answer helpful?

Score 0

Comments:

No VGA or HDMI attached. Just the cable from the Directv box. Thanks for the response.

by

Add a comment

Add your answer

JOHN WHITAKER will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 2

All Time: 71