Skip to main content

The SwagTron T3, released in 2016, is a self-balancing hoverboard that features LED motion indicator lights, bluetooth speakers, a built-in carrying strap, and a 5-level battery indicator.

12 Questions View all

Won't power on and charger light goes out when plugged in

This is a T6 Swagtron hover board.

It just stopped working while in use. I thought it was a loose wire, since it happened after someone hit something and fell off.

The battery was fully charged before it happened. Now, it won't power on at all. When it is plugged into the charger, the green light on the charger goes off. If I plug in the charger without plugging in the board, the green light on the charger is on. Then when I plug it into the board, I hear a pop sound and the charger light goes off. I'm thinking it is some type of short. Do you think it needs a new circuit board? Is there a way to test?

Answer this question I have this problem too

Is this a good question?

Score 2
5 Comments

Jeff Johnson, did you ever find out what was wrong?

by

I also have this same problem ..help

by

Same here faint poping noise when pluging in to plugged in charger, the thing was brand new less then a mile when it stopped working

by

@karlmatson does the light on the charger aswell on yours

by

Yes the light goes out on the charger when I plug the charger cord into the hoverboard

by

Add a comment

1 Answer

Most Helpful Answer

charger light going out would indicate a shorted component on the circuit board

Was this answer helpful?

Score 1

2 Comments:

Yeah was thinking this I have it all opened up what should I be looking for on the circuit board, i.e. any sorta indicators

by

@karlmatson can you post photos of the board

by

Add a comment

Add your answer

Jeff Johnson will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 26

All Time: 743