everything is working fine but there is no backlight

i found a guide online wich fuse to change about backlight but when i opened my camera it was different motherboard (it did not have that fuse)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The only other way would be to make sure that you have the right manual and it would be helpful if you have the information on your logic board.

Anyhow I posted a service manual with corrections on my file server for you to download and check if it helps. Again, if you can provide more info on your logic board, that would be great.

Level 1

Level 2

Level 3

Level 2 Supplement 2

Level 2 Supplement 4

Let me know if you have any furhter question, and good luck to you.

Was this answer helpful?

Score 2

Comments:

>EP GW< IBI,HF

1-865-826-11 SY-001

is this it?

by

Harbin Ametaj can you clarify this a bit? Is this.....???

by

these are the letters on the motherboard. are these the version number?

by

i checked the backlight "LEDs" they work but independetly when i try to power all 3 from the flex cable they don`t work !? today i`ll check does the camera provide power to the leds/SMD lights (sorry i don`t know what they are called)

by

Harbin, I think you are on the right way. Your LCD lights up but not when connected to the logic board by the cable. Make sure your cable is okay, without breaks and also your connector without corrosion. I am certain there is a fuse on your logic board. Check that one as well. I believe the number you gave me could be your logic board number. See in the manual if it matches. If your logic board does not supply the power, it is the fuse.

by

Add a comment

Add your answer

Harbin Ametaj will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 1,168