Repair for speakers, stereos, header units, and CD players for your car or truck.

108 Questions View all

Why my head unit functions but I get no sound?

2007 Land Rover LR3 SE audio not heard, but head unit working just fine. Every now and then the sound will come through.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

make sure your speakers work through Aux ports, or BT connections if you can. if they dont, then you will have a failing speaker set, and it wont be the Hardware. be sure to test Discs vs Radio Vs Aux. Make sure all are failing, or just one.

if your audio has network capabilities, running a firmware update may be required.

i would start with a full tear down. Remove the device, disconnect all cables, and reinstall the cables. could be a loose connection in the back. (if you occasionally get sound, that means the hardware works, and if the cables are loose, it would intermittantly send the signal to the speakers.

if you have access to a second Dash audio system, i would plug it in, and see if it fixes your issue. This will verify if it is something in either the car, or the system.

if these dont work, it gets a bit more tricky. Make sure the connections inside are proper. check the continuity of the cables with your multimeter, and as many 2pin components as you can. if you get a component that doesnt pass a 30 second continuity test, replace it. Anything further, testing would require full schematics of the specific audio system, and comparing present, and expected voltages.

Was this answer helpful?

Score 1


Thanks for the information Scott. Based upon your comments & suggestions it may be a speaker or wiring I issue. I will proceed to getting the wiring looked at next. Really appreciate your time to try to help!


Add a comment

Add your answer

Troy will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 7

All Time: 25