Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

594 Questions View all

Ear piece issue / unlimited boot / front camera flex

Hi, I'm here to address this issue and see if I can have some sort of explanation as well.

So I have now seen this problem 2 times.

Where after a repair is done, something is knocked off or something was done wrong.

But basically once the repair is complete your iPhone won't go pass the Apple logo.

Common issue I know. But keep reading.

The basics were done

Replaced the top flex cable

Used an original screen

Home button was good.

Even used the original screen from the first repair.

Nothing.

So here's a fix to get ACCESS to the home screen.

It took me forever to figure it out but here's my Conclusión

Put the iPhone in recovery mode

DFU or iTunes mode

You're gonna factory restart the phone.

So I did this twice and the pattern was the same

Once the phone is restarted it stays stuck on the logo

HOWEVER

if you disconnect the screen and the battery and reconnect it after the restart is done,

It'll go to the set up screen.

It's very odd and I don't know why it does this.

You'll notice it's going to be very glitchy.

Almost like you can't do anything.

My first thought is that it was the audio IC

But that is incorrect (keep reading)

So I tried different things like unplugging the flex connector.

But once I shut the phone off it never went to the set up screen again.

It's like it gives you access that one time.

So I factory restarted the phone again.

And same process with unplugging the device and plugging the screen back in

Same thing. It sets up the first time but that's it.

So I tried to restart it one last time

And the third time was the best one.

From there I could actually turn the phone off and on as much as I wanted although sometimes it took up to an hour to boot up.

I noticed a pattern in the flex cables on the top.

Because once it boot up and seemed perfectly functional. There was always a problem with the flex cables on top.

Either the camera

Or the proximity sensor

More commonly the ear piece wouldn't work

I couldn't even talk on the phone, the other person can't hear me and I couldn't even put It on speaker.

Its an issue alright.

I tried like 5 different flex cables from different companies

Originals. Everything

It was always something.

So on the first phone it's working good, I can turn it off and on as much as I want, the no phone calls is the only issue now.

The second phone I worked on that had the same issue.

Same thing someone replaced a screen and then it didn't want to boot pass the logo anymore

This time I did the same thing

Restarted through iTunes although it always came glitchy.

Tried different flex cables.

Nothing.

But I noticed when you take off the flex cable

And restart through iTunes without it being connected, once it finishes restarting, it'll be stuck on the logo of course

But if you unplug the battery and replug the top flex, it'll boot up and work fine (except the phone call problem popped up too)

So my question is what is this issue?

I tried contacting a friend that works at an Apple Store and does repairs and he commented saying they just replaced the whole board.

Seems idk, too much, i want a specific solution.

Any one seen a video about this or know what this is???

It's very frustrating please spread and help me find a solution

Tjanks

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

I have the same issue, I was trying to fix this for weeks.

All version of iOS from 11.2 ~ 11.2.5

Bootloop, Lagging on the screen / unresponsive

Front and Rear cameras not working

Volume Buttons takes too long to respons (2 -4 sec delay)

But I was able to partially fix this by upgrading to 11.3 (15E5178f) - you can download this at the apple developers page. Everything works except for the ear piece speaker, I'm sure it's not ear speaker or the flex because front cam works fine and when I try to make a call I can hear the dial sound coming out from the ear speaker, but when the call starts, no sound comes out from the ear speaker. The speaker button on the call menu is also disabled during the call.

Was this answer helpful?

Score 1

Comments:

I came to the same conclusion but I noticed that Siri or recording in general doesn’t work as well.

When you unplug and plug the front camera flex in the phone it’ll work for a little bit but after that it’ll go back to the same issue.

I’m wondering if it’s the audio IC after all

by

Siri doesnt work for me as well.

I’m wondering if it’s the audio IC after all

>> I don't think so, this is more of a software issue rather than hardware. It used to work on 10.3.3 but I made a mistake by updating to 11.2 - this is when my problem started. and there is no way for me to go back to the old version since apple already stop signing the older firmwares.

>>My band aid solution for this is to buy an small bluetooth receiver and that's what i used to listen to music and make phone calls. Iphone 7 doesnt have a 3.5mm jack anyway.

by

Add a comment

Hi everyone,


I have exactly the same issue than Oscar.

Still no explanation ?

Thks

Was this answer helpful?

Score 0
Add a comment

Add your answer

Oscar Gamino will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 19

All Time: 177