Released September 25, 2015. Model A1687/A1634. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

694 Questions View all

Why my phone gets very hot in seconds and drains insane the battery

My iphone 6s plus does not charging any more and if i put a charged battery it get stuck on apple logo, i can put it in recovery mode or dfu mode( it recognise the cable) but does not connect with the pc, can it have something else than the u2 chip?

Update (01/24/2018)

Now if i put the phone on airplane mode it work fine, even on antutu benchmark with airplane mode off i hot 80000 and airplane mode on 135000, it does not drains battery and does not get hot, can i fix it?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Chosen Solution

Your Tristar (U2) IC is probably damaged. This IC handles all communications with whatever is connected to the Lightning port...that includes the battery charger and computer. However it can happen that the charging is affected but not communications with the computer.

Was this answer helpful?

Score 2


Thanks for help, i took it to a repair shop and they told me its not the u2 ic because its not booting, can there be something else?


A failed U2 can also cause boot depends how the circuit fails. Did they even open it up and take a look at it?


Yes, they have change the u2 and now the phone is charging but still not booting or connecting to pc, i am not sure ifthey did it right


Since they already changed U2, then tristar isn't the fault here as it's still getting stuck on apple logo.

Have you tried updating the phone first to see if that helps? If you get an iTunes restore error, post it here.

Also if you want you can also try restore but only do that option if you dont have any data to backup from the phone.


Problem solved, it was a faulty rezistor and the u2 chip, now it works, thank you for your help


Show 1 more comment

Add a comment

Add your answer

Alin Ghetu will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 6

All Time: 470