Charging but not getting detected by laptop & crazy battery drain

Hi Guys,

I'm unable to connect my v10 to my windows laptop or any other OS or laptop. I always get an error message saying, USB Device not recognized. However, the only thing I can do is Charge my phone with it.

About the device,

Android Version: 7.0

ROM: Stock

SW Version: V30a-HKG-XX

I've tried almost everything. The following are what I've tried

1. Rebooting the phone and connecting again,

2. Tried on different laptop/computers, with linux and mac too,

3. Replaced the micro usb port,

4. Fiddled with device manager on windows, uninstalled drivers, reinstalled,

5. Tested with different data cables,

6. Tried connecting OTG usb drives,

7. Booting into Fastboot to see if it gets recognized there,

8. Updated from MM to Nougat,

9. Enabled USB Debugging, under dev options,

10. Enabled MTP, under dev options

All of the above did nothing to solve the problem.

I believe the data cables on the microusb port are fine and there maybe something wrong with the motherboard. Please tell me if I'm correct with this inference. if yes, then what may be done to solve this.

Please guys, suggest what maybe wrong and what can be done to fix it. I'd really Love & Hope it if there is a simple fix to it


Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment