My PB G4 Aluminum doesn't turn on after six months

Hi!

I have this PB for years now and it had issues before, but right now it just wouldn't turn on.

I wanted to start it and it just doesn't do anything, no chime, no fan, the chord doesn't light up and it seems just like dead. I did a PMU restart and took out and cleaned the RAM, but it just won't do nothing. I can't reset PRAM, because it doesn't move at all.

The point is that I didn't touch it for half a year. It wouldn't start six month ago, so I tried to start it with a friend's energy plug and it worked. I bought a new one yesterday and tried to start it, but no reaction. Maybe some battery went all out of energy.

But I just don't know what to do.

Thanks for your help!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

If your battery has totally drained, some Books won't start till they have some charge. Try removing the battery and starting. Please give us the last three numbers of your serial number(located in the battery compartment) so we know which Book you have. Thanks

Was this answer helpful?

Score 1

Comments:

Thank you for your fast reply.

I tried it with the battery removed, since the battery itself seems to be somewhat internally broken. But no reaction.

The last three numbers are SQ7.

Thanks a lot.

I'm really happy to have someone's help.

by

Apple PowerBook G4 1.67 15" (Al) Specs

Identifiers: 15-Inch 1.67/1.5 - M9677LL/A - PowerBook5,6 - A1106 - 2029

by

When you say it worked with your friends cord, did the adapter light up, did the Book boot? Did it boot to the desktop? Did it chime? You say it doesn't work now with the new adapter, does it still work with the friends adapter? If so, you got a bad adapter.

by

Okay, I try to find someone with the same PB version again. With this friend's plug everything went fine, it started, chimed and booted to the desktop. I bought the new adapter to have the "bad adapter error" erased :(

by

Hi!

I tried it with a friend's plug and it won't start as well. Same reaction as with my new plug: Nothing.

Is there still anything I can do to bring it back to life?

Thank you for your help.

by

Show 1 more comment

Add a comment

Add your answer

Jennifer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 949