2.0GHz, 2.3GHz, or 2.6GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache.

251 Questions View all

Another No Battery Available case

Hi,

I had just installed the ifixit battery replacement for my MBP 11,2 but the battery indicator on the menu bar says Battery not detected. I had cleared both SMC and PRAM several times over and over but nothing has changed. I even tried reinstalling the old battery and this time it also was not detected, whereas before this computer died on me some 5 months back, the battery indicator still read out the battery capacity (which was already showing how rapidly it would fully charge and discharge and shutdown somewhere around 70%).

This unit was rained on nearly 3 years ago but it did not incur damage as I prevented the water from soaking through the keyboard. But before it kicked the bucket, I had trouble with the 85watt adapter (it turned out to be a shorted wire where it exits the rubber grommet and gets flexed the most) and started using my wife's 60watt. This is around the time the erratic charging occurred, so before purchasing the iFixit kit, I brought it to the local Genius bar and had them run their diagnostic on it, thinking the DC-in Board was also faulty. It wasn't, but the results showed 2 defective sensors. The genius suggested the other sensor could've been battery related, perhaps the battery temp or something, while the other was the battery itself.

And so here we are. Ordered the kit, installed it with the string and solvent method, and, no go.

I was reading through other similar solved issues and one particular one caught my eye, regarding resoldering or cleaning a corroded resistor. I'm still using this MBP under wall power but if anyone can point out what I should look for on the logic board, I'll take out the screwdriver and take some photos.

Meanwhile, thanks and keep on soldering!

Update (01/16/2018)

@danj Did as you suggested and definitely found corrosion on the topside of the board. Proceeded to clean it up with a toothbrush and electronic contact cleaner (I didn't have 100%Isopropyl on hand and did not want to leave my workstation with the mac's delicate insides exposed to danger) . Screwed it back together and... Still an X on the battery. Reset SMC. but not yet pram. Here is a pic:

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Apple MacBook Pro "Core i7" 2.2 15" Mid-2014 (IG) Specs

Identifiers: Retina Mid-2014 15" - MGXA2LL/A - MacBookPro11,2 - A1398 - 2876

by

Actually a Late 2013

by

@flyin_flip - You'll likely need to take the logic board fully out as the back side is what likely got a bit wet and is messing up the charging logic.

Do take some good detailed pictures and post them here for us to see.

by

Add a comment

1 Answer

Chosen Solution

Block Image

Finally got it working. A few SMC and PRAM resets later.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Paul Ranada will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 27

All Time: 383